Help adding 433,92 motion sensor (rfxtrx)

Hi everyone!
I’m trying to add a Co-Tech 433,92 motion detector to Hass.io. I believe it uses Lightning 4.
I followed this procedure, and found the following in my log:

2019-01-30 23:07:47 INFO (Thread-2) [homeassistant.components.rfxtrx] rfxtrx: found possible device 8de4bd for 8a564d with the following configuration:
data_bits=20
command_on=0xa564d
command_off=0xde4bd

2019-01-30 23:07:47 INFO (Thread-2) [homeassistant.components.binary_sensor.rfxtrx] Added 
binary sensor 091300008de4bd017c60 (Device ID: 8de4bd Class: LightingDevice Sub: 0)
2019-01-30 23:08:01 INFO (Thread-2) [homeassistant.components.rfxtrx] rfxtrx: found possible 
device 899d2d for 8a564d with the following configuration:
data_bits=20
command_on=0xa564d
command_off=0x99d2d

2019-01-30 23:09:09 INFO (Thread-2) [homeassistant.components.rfxtrx] rfxtrx: found possible 
device 81da9d for 8a564d with the following configuration:
data_bits=20
command_on=0xa564d
command_off=0x1da9d

2019-01-30 23:09:09 INFO (Thread-2) [homeassistant.components.binary_sensor.rfxtrx] Added 
binary sensor 0913000381da9d017a60 (Device ID: 81da9d Class: LightingDevice Sub: 0)

It seems to me that the device uses different off signals(?).

When adding for example the following config as a binary sensor:

- platform: rfxtrx
  automatic_add: true
  debug: true
  devices:
    091300008a564d017c70:
      name: motion_laundey
      device_class: motion
      data_bits: 20
      command_on: 0xa564d
      command_off: 0x1da9d

I get the following error:

Invalid config for [binary_sensor.rfxtrx]: value must be at most 255 for dictionary value @ data['devices']['091300008a564d017c70']['command_off']. Got 121501
value must be at most 255 for dictionary value @ data['devices']['091300008a564d017c70']['command_on']. Got 677453. (See ?, line ?). Please check the docs at https://home-assistant.io/components/binary_sensor.rfxtrx/

Has anyone else added a device like this?

UPDATE:

After restarting Hassio, the motion sensor gets discovered again under yet a new ID:

2019-01-31 13:51:11 INFO (Thread-2) [homeassistant.components.binary_sensor.rfxtrx] Added binary sensor 091300018de4bd017a60 (Device ID: 8de4bd Class: LightingDevice Sub: 0)
2019-01-31 13:51:31 INFO (Thread-2) [homeassistant.components.rfxtrx] rfxtrx: found possible device 899d2d for 8de4bd with the following configuration:
data_bits=20
command_on=0xde4bd
command_off=0x99d2d


2019-01-31 13:51:31 INFO (Thread-2) [homeassistant.components.binary_sensor.rfxtrx] Added binary sensor 09130002899d2d017a60 (Device ID: 899d2d Class: LightingDevice Sub: 0)
2019-01-31 13:56:04 INFO (Thread-2) [homeassistant.components.rfxtrx] rfxtrx: found possible device 8a564d for 8de4bd with the following configuration:
data_bits=20
command_on=0xde4bd
command_off=0xa564d


2019-01-31 13:56:04 INFO (Thread-2) [homeassistant.components.binary_sensor.rfxtrx] Added binary sensor 091300038a564d017c60 (Device ID: 8a564d Class: LightingDevice Sub: 0)
2019-01-31 13:56:44 INFO (Thread-2) [homeassistant.components.rfxtrx] rfxtrx: found possible device 81da9d for 8de4bd with the following configuration:
data_bits=20
command_on=0xde4bd
command_off=0x1da9d

Did you try to receive the sensor with Lighting4 and AC enabled?

I Have enabeled Lightning4 and AC via RfxMngr. Should I also enable it in somewhere in Hassio config?

if the sensor is correct received in RFXmngr with Lighting4 and AC enabled you should enable this also in Hassio config.

Thank you!
Dumb question: how do I enable Lightning4 and AC in hassio config?

Sorry for bothering, but I still can’t get this motion detector configured in Hassio.
Is it possible that hassio doesn’t support 20 bits commands? If so, is there any way I could work around this?

Connect the RFXtrx to a Windows system.
What is received in RFXmngr if you enable Lighting4 and AC?

Thanks for replying. However, I think I figured it out myself. These are lightning5 devices, so I had to update the firmware to support it.

For everyone else wanting to add these cheap motion detectors from Cotech:
I needed to update the firmware for my RFXtrx433E, to get support for CoTech Smart home devices.
When that was done, Hassio would pick up the devices the right way.
Now I found the device ID in the log, and added it as a binary sensor:

- platform: rfxtrx
  automatic_add: false
  debug: false
  devices:
    0a1411030015191b010060:
      name: CoTech Motion sensor

Notice the debug: false here, i use this with the parameter true when adding new devices,.