Help- After power outage, I lost access to DuckDNS and HomeKit- local access still works

Tags: #<Tag:0x00007f73b32549e0>

So everything was working great until a power outage last night. I have surge protectors (whole-house, as well as dedicated ethernet and redundant on misc important devices.)

Once power returned, I was only able to access HA via Local IP. The app on my phone stopped (iPhone doesn’t trust the ‘invalid ip’ so the app was only running trough DNS). But what’s very strange indeed is that I lost control through Apple HomeKit but only on my Apple Watch and HomePod! It still works perfectly on my iPhone and MacBook.

Before I had the HomePod or even DuckDNS set up, I could still control everything with the watch and my phone so long as I was on the local network. The fact that I lost only the watch and the HomePod is just so confusing!

I checked all the port-forwarding, reservations etc. (My setup is a bit convoluted, so I was happy to confirm that no settings on any of the three routers involved had changed.) I verified that duckDNS still has the proper main ip. When I go to https://myduckdns.duckdns.org/ it says,
“This site can’t be reached
The webpage at https://myduckdns.duckdns.org/ might be temporarily down or it may have moved permanently to a new web address.
ERR_FAILED”

I’m only a month or so into HA so any help would be greatly appreciated!
Thank you greatly!
-Joey

Have you looked at the duckdns addon so that it’s running and no errors?
Can you connect using the external IP?

It’s not showing any errors. But I’m actually not sure how to connect using the external IP. Do you mean via DuckDNS?

Google what your external IP is anf try to connect to that using http(s)://IP:8123

Hmm, it says it’s unreachable!

What do you think? Thanks again for the help!

Hi,

Login to https://www.duckdns.org and verify that your IP-address is corresponding to the IP-address on https://www.whatismyip.com/

:+1: Verified! They’re a stunning match. Any other ideas?

And your external URL is correct in Home assistant? With HTTP/HTTPS and port? You can check if your port is open with:
https://www.yougetsignal.com/tools/open-ports/

1 Like

Sounds like your router is blocking the traffic.
Make sure it forwards the traffic on 8123 to the correct internal IP.

@Hellis81 @japper83

You’re both right! yougetsignal says they’re closed! (both 443 and 8123) I’m fairly new to port forwarding as well, but I’m a bright learning lad! Any ideas what settings may have changed do to an outage? Hoping for the clearest goal as possible as I’ll have to verify on three routers, each of different makes.

(my path, which has worked for weeks, looks something like this router-A: 443to443 > router-B: 443to443 > router-C: 443 to 8123)

Your making it a lot harder with 3 routers. Why are you using 3? Try forwarding only port 8123. Your HTTPS connection will still work.

1 Like

Three routers does not make it harder if they are wired and set up correctly.
(I have three routers myself)

However from your description it seems they are not.
Only the first router should have DHCP enabled, the other two should have an assigned IP address in the same range as the first routers range.
The cables should be connected LAN to LAN (only the first router should have the cable from “outside” connected to the internet port).

If you do as above only the first router needs to be set up with port forwarding (I would recommend you looking through all three routers and see which has the best options and use that as the first, if possible).
All the other routers will then be “dumbed down” to access points since they only serve the master router.
First router makes a decision all thers say “Yes sir”.

If you use wifi on the routers set up all three to have the same SSID and password, that way you can move freely between the routers without interruption.

Anyways, when all that I’d done then just port forward 8123 to 8123 on the HA IP and your done.

1 Like

To extend wifi past what one router can do.
And buying access points is far more expensive than routers since you can almost get them from free on the second hand market.

1 Like

Amazing! I absolutely want to implement this if you still think it fits my situation:

My wife and I live in a tiny house on wheels. It’s currently parked way-far-away from the main house on the property. The main house has the fastest DSL connection available- it’s a rural area. There is a very old shed with electricity about halfway between the main house are our tiny house. We wanted a direct connection, as my wife’s work requires a fast and stable internet connection. So I ran an outdoor/UV rated CAT6 from the main house to the shed, then from the shed to our tiny house (as well as to another outbuilding). I used, essentially the cheapest TP-Link router on amazon, in the shed to serve as an ethernet switch as well as WiFi to the surrounding area. (The distance was too far for me to go straight from the main house to the tiny house.)

So with that picture painted, what’s happening is that I’m basically daisy-chaining routers to get all the way to me, where I have a Google Nest Router, that the pi is connected to. The first router is also the modem, so it needs to be Router A. And I need to connect Router C (my house) to Router B (the shed) because of the distance. That said, is there an iteration of what you just explained that I should use to simplify my setup?

Also, because of you two, I found the problem! :trophy: Router B’s IP reservation for Router C somehow got lost and it was forwarding to the wrong IP! Everything works again!! :confetti_ball:

Side note for anyone else in the future:
As far as the Apple Watch situation, I believe when I set up my HomePod, apple, in the background, reprioritized my watch to access HomeKit solely through an internet connection, as HomePod acts as a bridge from my network to the internet. Which is really nice for voice control from anywhere. I’m not sure why this only happened with the watch and not my Mac or iPhone. My only assumption is that they’re attempting to streamline the watch’s interactions, as it’s just a lightweight, battery-fragile device. :man_shrugging:

1 Like

With that setup in mind, maybe the way I explained is not what you want.
When you connect LAN -> LAN then the same network extends.
If you connect LAN -> Internet you break the chain of the network.

Depending on your and the “main house” privacy could be the reason to choose one or the other solution.
When you extend the network, that means any shared devices/folders will be seen both in the shed/main house that is yours, and vice versa.

But apart from that then I’m quite sure that will be a working solution for you.
I have never daisy chained routers, but I don’t see any reason why it wouldn’t work.

The easiest way to do this is to disconnect everything from each router and focus on that router alone, then move to the next and disconnect everything from that.
You only keep one ethernet cable connected to the computer that does the set up.

And don’t type SSID and password (my own experience) use copy paste. It’s very easy to accidentally add a space at the end out of old habit.