Help Configuring BroadLink RM pro +

Need help configuring BroadLink RM pro +.

Here is my configuration in the switch.yaml

- platform: broadlink
  host: 192.168.1.37
  mac: '78:0F:77:18:32:C3'
  type: rm2_pro_plus
  switches:
    tv_panasonic:
      friendly_name: "Panasonic"
      command_on: 'AAAAAAAA=='
      command_off: 'AAAAAAAA=='

I used ihc to set up Broadlink on the local network.
I was able to use Broadlink Manager to learn power on and power off commands. Broadlink Manager resolved my device as “RM2 Pro Plus3”
Everything seems to work using either ihc or Broadlink Manager.

Using Home Assistant:

  1. boradlink.send command:
    host: 192.168.1.37
    packet:
  • “AAAAAAAA==” (copied command from Broadlink Manager)

returns error: returns error: "Failed to call service broadlink/send ‘192.168.1.37’

  1. broadlink.learn command:
    host: 192.168.1.37

returns error: "Failed to call service broadlink/learn ‘192.168.1.37’

I spend a couple of days on this. Looking through many posts. So far no progress.

Thank you

Those command_on and command_off are too short. Im using an RM Mini and this is an old Configuration that I use at some point. Now I’m using the remote option.


- platform: broadlink
  host: 192.168.100.200
  mac: 'b4:43:0d:fc:0a:f6'
  switches:
    tv2_power:
      friendly_name: "TV Family"
      command_on: 'JgDSAJSUEjgVNBM3ExIVDxYPExMSEhI3FjQVNRUQFRESERYPFRATNhQSFQ8VNRU1ExEVEhE4EhIUNhU1FQ8VEBU1FTQWEBQABfyVkhU1FTUVNRUQEhIVEBQQFg8UNhU1FTUSEhQSFBAUEBUREjgUEBQREjcTNxUQEhMVNRQQFjQVNRUQEhIWNBU1FBETAAX9lpEVNRQ2FDYUEBUQFBEUERQQFDYUNhQ2FBAWEBQQFBEUERQ2FBAVEBQ2FDYUEBUQFTUVEBM3FDUVEBQRFDYTNhYQFAANBQAAAAAAAA=='
      command_off: 'JgDSAJeQEzcWNBM3ExETExMRExIUERM3EzYUNhYPExITERMSExITERYQExETNxM3ExIVDxczFjQVNRM2ExMTERM3EzcWDhMABf6UkxM3EzYTNxMSFg8WDxMRExITNxM3EzcWDhMSExEXDxMRExIWDxMSEzcSNxYPFRAWNBM2FDYWNBMSExITNhM3ExITAAX9lJMTNxY0EzcTEhYOExITERcPEzcTNhM3ExITERMTFQ8WDxMRFw8SEhM3FjQTERYQEzYTOBU0FjMXDhMSFjQTNxUPEwANBQAAAAAAAA=='

    vsx_power:
      friendly_name: "Reciever"
      command_on: 'JgDYAAABFosWLxYMFjAWDBcMFi8XChgvFwwSMxIQFjAWMBYMFjAWDBIQEjMXDBYwFi8WDRYMFgwXLxIQFi8XDBYMFjAWLxcvEgADOwABFooWMBYMFjAWDBYNFi8SEREzFwwWMBYMFjAWMBERETQWDBYMFy8WDRYvFi8WDRYMFgwXLxYMFy8WDBcMFjAWLhcvFgADNwABGocWLxcMFi8WDBYNFi8WDRYvExAWLxcMFi8WLxcMFjAWDBYMFy8WDBcuEzMWDBcMFg0VMBYMFy8SEBIRETQWMBYvFgANBQ=='
      command_off: 'JgDYAAABGYgUMRcMFjAUDRYNFi8XDBYvFwwWMBYMFi8WLxcMFjAWDBYwFi8WDBYwFi8XDBYMFg0WDBYMFy8UDxMPFDEWLxcvFgADNwABGocWLxYMFjAWDBYMFy8WDRYvFg0UMBcMFjAWLxcMFi8XDBQxFjAWDBYvFy8WDRYMFA4UDxQNFy8WDRYMFjAWLxcvFAADOAABGocWLxcMFi8XDBYMFjAUDhQxFg0WLxcMFi8XLxQOFDEXDBYvFy8WDRYwEzEWDRYMFgwXDBYMFjAWDBcMFi8XLhcvFgANBQ=='
    shieldtv_power:
      friendly_name: "Shield TV"
      command_on: 'JgBIAAABKo8XDhMTFQ8WDxYPFQ8WDxYzFBETNhM2FjMTNxI3EzYTEhM2ExEWMxcOFw4TEhM2Fg8WDxM2ExITNhM2EzYTERczFgANBQ=='
      command_off: 'JgBIAAABJ5IVEBYPFBEUERUQEhIUERQ1FBEWMxQ1FDUVNBU1FDUWDxM2FQ8WDxUQExEWDxYzFRAVEBQ2FTQUNRU0FTQVDxY0FAANBQ=='
    vsx_volume:
      friendly_name: "VSX Volume"
      command_on: 'JgDYAAABFooWMBMPFjASEBIREjMSEBUxEhAWMBUNFjAVMBUNFjATDxYNFTAWDRUwFQ0VDhUNFQ0WMBMPFjAVDhUwFDEVMRQxFQADOQABGIgTMhYMFjAWDBUOEjQVDRQxFg0SMxUNFjAVMRQOFDIVDRMQEjIWDRUwFQ4UDhUOFA4VMRYMFjAUDhUxFTAWMBUwFQADNwABGocUMhUNFDIUDhUOFDEWDRQxFQ0WMBUNFTEUMRQPFDEVDRUNFTEWDRQxFg0VDRMQFA4UMRYMFTEWDBUxFjAVLxUyFQANBQ=='
      command_off: 'JgDYAAABGYcTMxIQEzMTDxMQEjMSEBUxEhAUMhIQEzMUMRIQFTETDxUxEzMTDxQxExASEBQPEhAVDRUNFjATEBUwEzITMxUwEwADOgABGYgUMhMQEjITEBIQEjMVDhMzEhATMhIQEzMTMxIQFDISEBQxEzMSEBQyEhAUDxMQEhASEBQPEjMTDxMyEzMTMxIzEwADOQABGYgTMxMQEzITDxQOFTETEBQwExATMxIQFDITMhUOFDETDxQyEjMTEBI0Ew8SERMPEw8UDhIREzIUDhQyFDITMxMxEwANBQ=='

Maybe you can try with the remote option of Broadlink component. You just call the service with a device name and a command name. After all the commands are learned you can find the file on ./storage/broadlink_remote_‘mac_of_your_device’_codes.

remote:
  - platform: broadlink
    name: Broadlink Family
    host: 192.168.100.200
    mac: b4:43:0d:fc:0a:f6

After I replaced my previous configuration with remote option, I was able to use service remote.learn_command and remote.send_command to operate panasonic tv. here is my updated configuration:

remote:
  - platform: broadlink
    name: tv_panasonic
    host: 192.168.1.37
    mac: '78:0F:77:18:32:C3'

Thank you!