Help me register a Yale YRD210 Z-Wave lock?

Hey folks, I’m trying to add a Z-Wave lock to Home Assistant and I’m absolutely stumped. I’m new to Home Assistant, so please go easy on me.

I’m using the Zooz ZST39 USB stick, which is plugged into my Home Assistant Green via a USB extender. I successfully added a Minoston Z-Wave 800 Series Zwave Plug. So I know that the hub and at least one Z-Wave device work.

Now the problem: I’ve been unable to add a Yale YRD210 with ZWave module deadbolt. I try to include it, and then push the keys indicated in the manual (master code#, 7#, 1#) to register the lock. However, the inclusion process times out, every… single… time.

  • I tried moving the already-registered plug closer to the lock to ensure it was in range of the network, and still no luck.
  • I tried both with and without the “security required” checkbox checked, and still no lock.
  • I tried factory reset on the lock, and still no luck!

I’m kind of stumped as to what I can try to debug next. Anyone able to help?

Thanks,
Bret

I put the HAG on long cables, held up the zwave hub stick on a USB extension within just a few feet of the lock, and found inclusion was still not working. Something else was wrong!

Eventually I had to call Yale. We walked through taking out the batteries, removing and reinserting the zwave module, then the batteries, and then (this was different!) ran exclusion with the zwave hub right next to the lock. That seemed to work, in that the exclusion dialog terminated early rather than waiting the full duration. After that I was able to include the lock!

I’m guessing this is because the lock was still set to work with my old hub, and the new hub was out of range when I’d tried to exclude it previously.

(BTW, it looks like the manual I linked above is wrong! This one has a slightly different programming flowchart.)