Help needed with setting up SSH Server add-on

I’ve tried many times to get SSH Server add-on to work but I’m at a loss. I use Linux as my main OS and have generated a public key using the following:

ssh-keygen -t rsa -b 4096 -C "hassio"

I then copy and paste the generated public key into the [] in the following and save:

authorized_keys: []
password: ''

I then click ‘Start’ on the add-on but nothing happens except for the start button briefly turning red. There’s no output in the add-on Log, it literally appears to do nothing.

I think I have fixed it myself. The container was set to 22. I’ve tried setting it to 23 and it now works.

22 is default ssh, 23 is default telnet. Almost sounds as if something was already running there. But if it works, it works.

I wonder if port 22 is already in use? My install is on a Ubuntu server.

about 99% it is :slight_smile:

I’ll change it to a random port in the dynamic/private ports range: 49152-65535 so not to class with any system ports.

Yep already in use, I had the same problem. I run HA SSH on port 23 on my Ubuntu Server, seemingly with no issues. I made a bit of a fool out of myself asking the question on Github :sweat_smile: and added the detail in my setup guide to help others avoid the issue!

Siytek, nice guide :+1:

Just one suggestion, you might want to consider using one of the private ports in the range of 49152-65535 instead of port 23, as that is commonly used by Telnet, which may also be running on some Ubuntu server configs.

Thanks @bedfellow :smiley: I didn’t think of that and you’re quite right, I should probably give it a mention. I think most folks will scratch install for HA but there is bound to be someone who’s running Telenet on the same machine for some reason.