Help Please - Having issues setting up DuckDNS with dehydrated script

So I have tried to setup duckdns and let’s encrypt using the directions laid out in Andreas write up: HASS, DuckDNS and Let’s Encrypt

I get to the point of generating the certificates and I run into an error after it responds to the challenge for my duckdns domain:

  • Responding to challenge for myduckdnsdomain.duckdns.org
    OK
    Unknown hook invalid_challenge
    ERROR: Challenge is invalid! (returned: invalid) (result: {
    “type”: “dns-01”,
    “status”: “invalid”,
    “error”: {
    “type”: “urn:acme:error:connection”,
    “detail”: “DNS problem: NXDOMAIN looking up TXT for _acme-challenge.myduckdnsdomain.duckdns.org”,
    “status”: 400
    },
    “uri”: “XXXXXXX”,
    “token”: “XXXXXXXX”,
    “keyAuthorization”: “XXXXXXXX”
    })

I am unsure what to try next. I have tried looking into if it was a DNSSEC error using dnsviz and it looks like the request makes it to duckdns.org - I am unsure what to try next. Any ideas/ suggestions?

Edit: Also, I am attempting to do this on Raspbian Stretch as the homeassistant user and while in the python virtual environment.