[Help] Qingping Air Monitor Lite, unable to pair it

Hello there,

Short summary : i had HA installed on a Pi, migrated to a NUC, everything went fine, youpi !

But, i’ve noticed that my Qingping CGDN1 Air Monitor Lite was not showing any data after the migration… so i went to reset it, update it to latest bios, and re-pair it

But… i’ve discovered that HA never detect it.

After a few hours of testing :

  • HA detect it only a few minutes after being fully reset, it appears as HomeKit Sensor

  • However, 5 - 10 minutes after connected to Wifi using the app : it dissapear from HA
    But it still “pingable”

  • If i click on “Configure” → It remain with the message “Please wait, starting configuration wizard for the integration”

  • I don’t see anything in the logs. Only thing i’ve got, but i wasn’t able to capture it was an exception in the log saying that the device didn’t answer

I’ve tried many things (be faster to import it within HA, unpair from the app, summoning dark entities) but i wasn’t able to pair it back with HA

I haven’t tried to pair it with Xiaomi Home app, only Qingping. It seems my model isn’t handled by home app. So i wasn’t able to get a token for MIOT

Firmware is 4.6.3, connected to Wifi with a dedicated IP (set through DHCP reservation)

If someone has an idea…

Have you tried pairing it with the apple home app on an iPhone or iPad and then removing it from the home app and pairing it with the HA home kit controller integration?
I have a qingping lite that I have to re-pair every few months this way because it sensors become unavailable in HA. Have tried other things like rebooting the qingping, reloading HA integration but nothing seems to work

I have tried, but without success.

But, i was able to pair it now with Xioami Home using the China servers (Qingping Monitor doesn’t exist when connected to EU servers - That’s why i wasn’t able earlier)
So with that, i was able to use MIOT with my credentials, directly to China servers and import it in HA

1 Like