Help Request accessing after backup restore

Hey HASS Community.

I had HA running on my Raspberry Pi3b+ for a while now.
Suddenly it stopped booting up without me making any changes to the system.
After connecting it to a screen and trying to boot it up again i ran in to an issue with the SD-Card.
I did a bit of research and found out that a section of the SD-Card was corrupted.
Trying to fix it with a Ubuntu installed PC didn’t work out for me, sadly.

I saved the backup files i found on the card. Now i tried restoring the Backup in a VM on my Win10 PC (which is working perfectly fine, so that shouldnt be the Problem).
Before restoring the Backup reaching the HA with homeassistant.local:8123 worked.
Afterwards i tried it again but i m not getting a response at all.

I had a look at the observer using homeassistant.local:4357 and everything is fine regarding to the information i found there.
BTW i tried accessing the instance over the local IP already. If i try to ping it i get a response, but accessing the WebUI isn’t working at all.

Any Information to help me out? :confused:

Thanks for your support already!