Help....restore state and spontaneous restarts on .80.+

has anyone here solved this on their 0.80.+ installs?
see: https://github.com/home-assistant/home-assistant/issues/17412#issuecomment-432142564 and https://github.com/home-assistant/home-assistant/issues/17511

  • intermittent spontaneous restarts,
  • restore state isn’t respected (half of the time or so) and
  • hang on restarts every 1 out of 3 restarts…

Not very reliable at the moment i am afraid, and nothing I could come up with helped. Disabled all packages , all custom components, ended up with a practically empty configuration…

Hope anyone has a clue of a direction for a solution…

i had and still have some of the same issue’s.

Running Ubuntu 18.04 on a intel nuc i5.

First of all when i download the new docker image the following error appeas:

/usr/local/lib/python3.6/site-packages/psycopg2/__init__.py:144: UserWarning: The psycopg2 wheel package will be renamed from release 2.8; in order to keep installing from binary please use "pip install psycopg2-binary" instead. For details see: <http://initd.org/psycopg/docs/install.html#binary-install-from-pypi>.

i thought this might be related to the spontaneous restart and found this on github https://github.com/home-assistant/home-assistant/issues/12396

after removing psycopg2 and installing psycopg2-binary inside the container it looks a lot more stable.

Also i found that the nmap scans were failing.
therfor i added

scan_options: " -sP --host-timeout 10s"

and nmap is working almost 24h with no problem.

I still have the binary ping sensor failing from time to time.
no fix found yet.

Hope this might help with your issues.

that might be a hint indeed my settings are: scan_options: " --privileged -n -sn " though I have no idea what that means … copied it from the main documentation settings or some other configuration.

would you be able to explain that a bit?

i copied this from a post on the forum.

to be honest i have no clue what the parameters do i need to look in to that.
but for now the nmap doesnt show any error’s which was priority for me.

ok thanks, will try some, here’s the options summary:

https://nmap.org/book/man-briefoptions.html

btw, no sP is listed there…

i was just looking for -sP :wink:

i think its a ping scan.

Ping scan: sn

38

thats correct :

user@nuc:/usr/src/app# nmap -sP -v 192.168.5.16
Warning: The -sP option is deprecated. Please use -sn

Yesterday i added this workaround for the ping sensor:

No error’s have come up since.

yes I tried that too, but the thing is, Hassio wouldn’t connect any more. Seems to be an issue with 0.80 also but it was intermittent. With this workaround it was sticky…

will test again to be sure.

Sorry you have no idea how to type

nmap --help

??