Help with configuration with duckdns and Home Assistant IOS App

After successfully installing duckdns for the first time in years, I am having problems with the iOS app. It keeps giving me errors and not connecting. Can someone give me the proper internal and external url addresses to fill out using duckdns.org?

You have to use the same address for both. You can’t specify a secutity exception to allow the app to use https://<ip_address>:port like you can in a web browser.

So just use https://<your_domain>.duckdns.org:<port> for both and rely on NAT loopback in your router for local access via that URL.

If you forwarded port 8123 internal to port 443 external you can leave the port number off the URL. If you specified any other port (like 8123 to 8123) you must specify it in the URL.

OK, so I am still having problems and I am using port forwarding. Nothing is working here.
external

Here is my configuration yaml base_url: https://<my_domain>.duckdns.org

I am using external url as you have stated above without a port on it.

The error it gives on the screen says this:
The certificate for this server is invalid. You might be connecting to a server that is pretending to be “<my_domain>.duckdns.org” which could put your confidential information at risk.
NSURLErrorDomain -1202

What port forward rule did you add to your router?

443 to 8123. Everything works in a chrome browser, just not the ios app

If you delete the app from your phone then add it back while you are connected to the local network it should automatically set the connection up for you.

Now mind you that I have an xfi router that my house is on. Home assistant is plugged into a tp-link router that allows it to see all my devices in the house. The xfi router does the point forwarding so if I am using the app it is always on an external server. Does that make a difference?

I did the reinstall app method and it never connected. Gives me the same error code. This time it is trying to use internal url, but I have them both set to the same url.

Yes. Sounds like you are double NATing which won’t work.

IF it works in a browser, why wouldn’t it work on the app?

Did you have to add a security exception in the browser for it to work?

Yes I told it to continue on. The second router doesn’t have a NAT forward on it.

That’s your issue. There is no provision to add this type of exception in the app.

Explain how your network is set up.

From the cable it heads to the cable modem provided by xfi, but that just acts like a internet switch with no wifi enabled. I have a tplink router plugged into that ethernet of the xfi router that can pick up all the devices in the house. To get duckdns to work, I port forwarded on the xfi router alone. The tplink isn’t port forwarding anything at all.

Is the xfi device using the same internal IP range as the tplink?

Just pulled it up and no it is not using the same internal ip ranges.

That’s where your double NAT (network address translation) is occurring.

and there is no way of getting around that at all?

I am not a networking expert so take this with a grain of salt but I if you can’t remove one of the routers from the network you could perhaps put the xfi into bridged mode.

agreed and understand what you are saying… Thanks for the help!