Help with HA Utility Meter recording omission (from Esphome sensor) at midnight

Hello fantastic Home Assistant community!

I have an issue with my Utility Meter readings for gas and electricity, based on esphome (pulse meter) sensors.

After resetting at midnight, the Home Assistant Daily Utility Meter seems to have a delay before it registers new values. If my esphome sensors send a new value within this period (not sure how long it is, maybe only a few seconds, up to a minute?) they are ignored by the Utility Meter (and not added when the next value is registered), leading to the Utility Meters recording lower readings than the esphome sensors.

Does anyone know of a way around this from within Home Assistant? I haven’t been able to find one on the forums.

On the esphome side I have been trying (unsuccessfully) to find a way to get the sensors to send values at specific times (eg 00:05 and then every 10 minutes).
I have tried using “interval” and “time” settings to force the above times, both report an error that the (pulse meter)
“Sensor doesn’t inherit from polling component”

I have also unsuccessfully tried to create a lambda to do this:

 - platform: total_daily_energy
    name: '${friendly_name} Daily Energy'
    id: sensor_total_daily_energy
    power_id: sensor_energy_pulse_meter
    unit_of_measurement: 'kWh'
    icon: mdi:circle-slice-3
    state_class: total_increasing
    device_class: energy
    accuracy_decimals: 3
      - multiply: 0.001                                              # Multiplication factor from W to kW is 0.001
      - heartbeat: 60s
      - lambda: |-
          auto now = id(my_time).now();
          if (now.hour == 22 && now.minute == 25) {
            return x;
            ESP_LOGI("main", "The lambda sensor reports value %.2f", id(sensor_total_daily_energy));
          else return x;

The lambda didn’t seem to produce /effect any sensor output.

Any help would be much appreciated