Help with Pi_Hole Statistic sensor

Hi guys, I just installed HASSIO for the first time :smile: and I try to add Pi hole statistics using a sensor but it is giving error.

    host: 'localhost:4865'
    ssl: true
    verify_ssl: false

Any ideas or suggestions on how I can fix this?

Is pi-hole installed and running?

Yes Pi-Hole is installed and running.

Obvious question here. Did you try with

  ssl: false

? It’s very unlikely that you have a certificate for ‘localhost’.

yes I did. but I will try again and I will reset the add on too just in case

I change it to false and reset the add on and It start working :smiley: Thx for the help :smiley:

And how did you install it?

I used the add on that is on the add-on store

Hi, do you know any good looking lovelace card (with Pi-Hole on/off switch)?

I can’t find any service for checking if Pi-Hole enabled or disabled?

Thanks, RaKa

No, Sorry.

I think pi-hole only reports sensors, I don’t think the HA integration has the wherewithall to switch pi-hole on and off.