Help with web scrape

I would like to scrape the weight value from this web page-

I’m not sure if it’s possible or not but definitely out of my abilities.

Sorry, wrong screenshot.

Tried using this entry in configuration.yaml-

sensor:
  - platform: scrape
    name: Hive 8 Weight
    resource: http://www.wifihivescale.com/index.php/login
    select: "#t01 > tbody > tr:nth-child(4) > td:nth-child(6)"
    unit_of_measurement: lbs
    username: redacted
    password: redacted

This results in an error-

Logger: homeassistant.components.scrape.sensor
Source: components/scrape/sensor.py:147 
Integration: scrape (documentation, issues) 
First occurred: 2:44:39 PM (1 occurrences) 
Last logged: 2:44:39 PM

Unable to extract data from HTML for Hive 8 Weight

I’m guessing “select” is probably not set correctly. This is all new to me and I could really use some help.

I set authentication: digest just as a test. I get this error-

Error while setting up scrape platform for sensor
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/helpers/entity_platform.py", line 199, in _async_setup_platform
    await asyncio.shield(task)
  File "/usr/src/homeassistant/homeassistant/components/scrape/sensor.py", line 82, in async_setup_platform
    await rest.async_update()
  File "/usr/src/homeassistant/homeassistant/components/rest/data.py", line 54, in async_update
    response = await self._async_client.request(
  File "/usr/local/lib/python3.8/site-packages/httpx/_client.py", line 1371, in request
    response = await self.send(
  File "/usr/local/lib/python3.8/site-packages/httpx/_client.py", line 1406, in send
    response = await self._send_handling_auth(
  File "/usr/local/lib/python3.8/site-packages/httpx/_client.py", line 1438, in _send_handling_auth
    request = await auth_flow.__anext__()
  File "/usr/local/lib/python3.8/site-packages/httpx/_auth.py", line 92, in async_auth_flow
    request = next(flow)
  File "/usr/local/lib/python3.8/site-packages/httpx/_auth.py", line 115, in auth_flow
    yield self._func(request)
  File "/usr/local/lib/python3.8/site-packages/requests/auth.py", line 292, in __call__
    r.register_hook('response', self.handle_401)
AttributeError: 'Request' object has no attribute 'register_hook'

Checking HA issues I see that this issue has been reported. Perhaps there isn’t any configuration error on my part and I just need to wait for this issue to be resolved? Hoping someone could confirm this.