Hide_entity Not Working For Automations

I’m trying to hide my automations from the UI by adding hide_entity: true (or hide_entity: True, I’ve tried both) to each of them, but they just won’t disappear. I’d really like these hidden so that I don’t accidentally edit an automation that’s too advanced for the UI, which would wipe out some of the data.

hide_entity seems like a pretty straightforward option, so I’m kind of baffled why this isn’t working, and I’m hoping someone might have a suggestion.

- id: '1546706499176'
  alias: Lights (Bedroom Lamp) -- Adjust brightness depending on time of day
  initial_state: true
  hide_entity: true
  - entity_id: light.bedroom
    platform: state
    from: 'off'
    to: 'on'
  condition: []
    service: homeassistant.turn_on
      entity_id: light.bedroom
      brightness_pct: >
        {%- if now().strftime('%H')| int >= 21 %}
        {%- elif now().strftime('%H')| int >= 20 %}
        {%- elif now().strftime('%H')| int >= 9 %}
        {%- elif now().strftime('%H')| int < 9 %}
        {%- endif %}

Weird, it works for me. Have you reloaded your automations or restarted since adding hide_entity:?

Weird indeed. I’ve tried restarting, rebooting, removing and then slowly re-adding the hide_entity lines, and nothing has worked, I just can’t get the automations to hide in the UI.

The only difference between my hidden automation config an yours is that I do not specify:

  initial_state: true

It’s a long shot but what happens if you comment out that line, reload your automations and refresh your browser cache (CTRL+F5)?

EDIT: actually before doing that, what happens if you refresh your browser cache?

Hi gjch,

I had the same thing yesterday when I converted my UI to LoveLace with the addon.
I’m using Hassio on a Rpi.
For me it disappeared by itself, now the automations are not showing anymore.
Maybe it will be the same for you…

@tom_l, I’ve tried removing the initial_state option, clearing my cache, a few different browsers, and even removing the hide_entity option from my automations and instead using the customization section to hide them instead, but still no luck.

I’m in the exact same situation @MPJK77, running Hass.io on an RPi and just started converting to lovelace yesterday. Hmm, maybe I’ll give it some time and see if it decides to clear itself up like it did for you.

That’s really odd. I’m out of ideas, sorry.

It`s not working for me too :slight_smile: I thought the reason is lovelace.

I can confirm it is not working. Should we open a bug-issue on Github?

Btw. do you guys think this option really should hide the animation from the UI? I dont find any documentation on this option.

I too am seeing my hidden automations in unused_entities. According to the last example on this page, hiding should be an option:

@tom_l @MickL

Hiding in customization and though any means (outslide lovelace.yaml) does nothing in lovelace. It is a legacy UI property. If you want to hide automations in lovelace, don’t add it to the UI. Lovelace is an opt-in UI, meaning you have to add what you want. The old ui was opt out, meaning everything was added and you had to hide items.

1 Like

Is it possible to hide an automation from the configuration section of the frontend? - i.e the list presented for editing in the automation editor. I for one assumed that is what the

hide_entity: true

would do.

I simply have too many automations that I do not wish to manually toggle or monitor… and they clutter the list from the few that I wish to monitor and possibly manually toggle or edit.

That is for the legacy UI. In the legacy UI, all items were added to your interface. You had to hide them if you didn’t want them.

Lovelace is opposite. If you want an item in your interface, you have to add it. This only occurs though once you take control of Lovelace. If you don’t take control of lovelace, everything is added by default.

So, take control. Remove what you don’t want. Take a look at the lovelace documentation to figure out how to manipulate the UI.

When I say “Take Control”, I’m referring to the first time you edit Lovelace.