Hive Heating UK

hi @Frazzyfin

if you are looking to use the built-in component for Hive, then all you need is:

  username: YOUR_USERNAME
  password: YOUR_PASSWORD

are you seeing any errors in your log?

I’ve tried removed the climate part in my configuration.yaml, but i’m still not seeing anything to do with the Hive on my dashboard. Nothing about Hive in my home-assistant.log either.

Ok I’ve increased the logging level and these are the only lines containing the word “hive” after a restart of hassio. One of the lines is “Setup of domain hive took 7.2 seconds.”, so why can’t I see anything on the dashboard?

The entities are climate.heating and climate.hot_water, no hive in the names

Ok so are you saying I should be looking for climate.heating in the logs?

Also on the hassio about page it says Hive is loaded.

Does it not appear in dev-states?

Unfortunately not.


What hive devices are you expecting to see?

thisno longer works in 0.89.0

specifically what no longer works?

the hive custom component does not work at all in 0.89.0 works fine in 0.88.1

hi @grom.m20b25

understood. this is being discussed in another thread too:

Has anybody been able to add the Hive TRV vales to HA yet?

Hi @jjtyper, Support for Hive TRV is being worked on, maybe available late summer

1 Like

Hi @rendili, Is there any support in testing i can give you on this?


There was a PR submitted to make this live in to Home Assistant, so it should either make the next release or the one after

1 Like

Is it possible to check the battery level of the TRV valves in home assistant.
There seems to be a battery level for the main thermostat, but not for the TRVs ?

How would I raise this as a feature request if it doesn’t exist at the moment?


1 Like

Anyone else having Hive problems after updating to HA vsn 0.110.3 ?

I get the following error in the log:

Log Details (ERROR)
Logger: homeassistant.setup
Source: components/hive/
First occurred: 27 May 2020, 23:58:56 (1 occurrences)
Last logged: 27 May 2020, 23:58:56

Error during setup of component hive
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/", line 175, in _async_setup_component
    component.setup, hass, processed_config  # type: ignore
  File "/usr/local/lib/python3.7/concurrent/futures/", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/src/homeassistant/homeassistant/components/hive/", line 125, in setup
    devices = session.core.initialise_api(username, password, update_interval)
  File "/usr/local/lib/python3.7/site-packages/pyhiveapi/", line 879, in initialise_api
    if product["parent"] == device["props"]["zone"]:
KeyError: 'zone'

Seems to have been a problem with Hive. The Hive app was also not responding, so I went through the diagnosis in there and it started working again.