Hive integration now has errors

Hello,
My previously working hive integration now has errors,

File “/usr/src/homeassistant/homeassistant/components/hive/config_flow.py”, line 93, in async_step_2fa

return await self.async_setup_hive_entry()

File “/usr/src/homeassistant/homeassistant/components/hive/config_flow.py”, line 108, in async_setup_hive_entry

await self.hive_auth.device_registration(“Home Assistant”)

File “/usr/local/lib/python3.9/site-packages/apyhiveapi/api/hive_auth_async.py”, line 460, in device_registration

File “/usr/local/lib/python3.9/site-packages/apyhiveapi/api/hive_auth_async.py”, line 480, in confirm_device

2022-06-12 13:56:47 ERROR (MainThread) [homeassistant.config_entries] Error setting up entry “email address” for hive

File “/usr/src/homeassistant/homeassistant/components/hive/init.py”, line 89, in async_setup_entry

devices = await hive.session.startSession(hive_config)

File “/usr/local/lib/python3.9/site-packages/apyhiveapi/session.py”, line 493, in startSession

File “/usr/local/lib/python3.9/site-packages/apyhiveapi/session.py”, line 416, in getDevices

await self.hiveRefreshTokens()

File “/usr/local/lib/python3.9/site-packages/apyhiveapi/session.py”, line 303, in hiveRefreshTokens

File “/usr/local/lib/python3.9/site-packages/apyhiveapi/api/hive_auth_async.py”, line 537, in refreshToken

Home Assistant Core 2022.6.5

Home Assistant Supervisor 2022.05.3

Home Assistant OS 8.1

Have a search on here, there’s a few threads about it, there’s some issues recently

Hello,
I deleted all references to the integration, changed the email address on the Hive app for another email, with TFA, added the integration with the new email log on, all now works!

I had this issue, I just turned on 2FA within the Hive app (can’t do it on the website) and then added it again, all working.

2 Likes

Same here. Seems counter-intuitive, but this is the solution.

Thank you for sharing this. This is really helpful! Now mine is set up too. :smiley: