Home_assistant 404 not found

Hey all,

So I’ve been trying to setup HA and google_assistant but have been hitting a brick wall.
I’m running HAOS with supervisor and pushing it through an NGINX reverse proxy.

I believe the issue is that the URL: https://ha.myDomain.com/api/google_assistant results in a “404: Not Found” error. I tried hitting it directly using the IP address: http://192.168.0.14:8123/api/google_assistant which returns the same result so I don’t believe it’s a proxy issue. The /auth/authorize URLs still behave as expected so I believe its something related to google_assistant specifically. Is there a step i’ve missed like enabling the google_assistant addon or something?

I’ve searched around and not been able to find anyone having a similar issue. Does anyone know why this might be happening?

Thanks

1 Like

Did you already set Google assistant in your config? The url won’t work until that is complete and after reboot.

1 Like

That was it, I jumped the gun without putting the config in.

hmm, in my case the google yaml config is loaded, but when i browse to :

https://xxx.duckdns.org:8123/api/google_assistant

i also get 404 not found , verry strange

any idea?

google_assistant: !include google.yaml

and in google.yaml

  project_id: !secret google_proj
  service_account: !include hassio-xxx.json
  expose_by_default: false
  report_state: true
  entity_config:

hmm, seems if i rollack to 2021.12.x , i get back 405 , so can link again

if i update to 2022.2.1 , i get 404

what do you get now on release 2022.2.x ?

Hi

did you find a solution? I have the same problem

This thread 2yrs old

It may sound the same but 2 many changes since then. You need to provide details
Logs
How you test