Home Assistant + Alexa

Hi,

I just removed Home Assistant cloud. I have created a new domain under https (443). Now I want to link Home Assistant with Alexa without using Home Assistant Cloud. When I add Home Assistant skill at alexa on amazon.com, I need to log in with home assistant cloud.

How should I go now when I do not want to use Home Assistant Cloud?

Solution: Haaska?

Haaska is the (only?) option if you don’t want to use Home Assistant Cloud. Mind you that it has a lot of moving parts:

  • Exposing your HA to the internet with a long-living token
  • building a haaska package
  • creating an alexa smart home skill on a developer account
  • configuring haaska on amazon Lambda
  • Tying it all together with Amazon Login

For me it took the better part of an evening to get it all up, rummaging through outdated guides and Youtube videos so it’s not for the faint of heart.

Configuring haaska on amazon Lambda:
An AWS account is required. Free for 12 months, but they want my credit card number for month 13 onwards. What does it cost? Cheaper with H.A cloud?

It’s hard to run out of the free usage with only haaska as your lambda function.
You can run 1M requests per month without paying anything: https://aws.amazon.com/lambda/pricing/

Set a balance alert so that as soon as anything in the AWS starts costing money, you get an e-mail. So far, i’ve had to pay 97 cents for some storage that I forgot to remove.

As for Lambda, the free tier gives you 1 million requests or 400,000 Gb/seconds of execution time. Alexa discovery costs about 30 Mb and around 800ms. That’ll be good for thousands and thousands of alexa calls per month. I’m pretty sure you won’t talk to her that much so don’t worry about it.

I followed several procedures but actually identical.
I created amazon accounts indicating payment methods
It didn’t work for me

I don’t understand why you want to skip duckdns and nginx. The solution has been right in front of you but you refuse to use it.

Add nginx. (FREE)
Add duckdns. (FREE)
Add Alexa Smart Home Skill (FREE)

The effort you’ve put in to avoid this solution has definitely surpassed the amount of effort that the solution takes.

I enabled duckdns and followed the web tutorial procedure for haaska. Negative final test. I don’t know what’s wrong

What server did you end up using? I’ve noticed that most don’t work accept for NA Virginia

Europe irland

Try switching it to NA and see if it works. Also, make sure you aren’t exposing media_players. Some media_player devices cause discovery to fail.