Home Assistant Core on Android Tablet

can you try downloading apk and installing manually? Lineage 13 is not old enough :slight_smile:

yes, and it worked :slight_smile: thanks
unfortunately, home assistant installation generated soooo many errors.
I’m afraid my tab is too old :frowning:

Perhaps you could use a RPi 4 as the HA server and combine it with the tablet as a wall mounted console?

that’s an interesting possibility

I’d say that’s the base case for any tablet that’s too old to run the Home Assistant server - regardless of how old, it should be possible to install the companion app and using it as a wall-mounted UI.

Is there a way to install add-ons. There a lot of options not available with the core version like Hacs.


HACs is not an add-on and can be installed on core.

can you please give me idea how. I have zero skills on termux and linux in general


You start there and read, then click next, then scroll down to the instructions which matches your install.

Shameless to say I need step by step instruction. Is this installation a Home assistant container or Home assistant Core?

Look at the thread title, what does it say? :wink: It is HomeAssistant Core. :slight_smile: But don’t worry, you will get there! :wink:

Thank you. I did it. I can now control my Sonoff devices

Great step by step guide.
I made it to SSL Certificate, than I just gave up end subcribe to HA cloud (i’m beginner for this stuff)
I have a question though.
I’m using nexus 5x phone for my project.
What is the easiest way to display sensors (5 temp, 5 humidity) as large as possible.
I try to use Bignumber-card in lovelace but got stuck.

Excellent instructions. Just got this up and running on a Tab S2 running LineageOS 16 and a Note 10.1 running LineageOS 18. The Note had been sat gathering dust so nice to have a use for it.
I’m only things locally while I experiment so I haven’t done any of the things to allow remote access. From doing this a couple of times I would make two changes to the instructions:

Get ssh running before anything else - you can then use your PC to do all the typing and use a proper screen which makes it much easier.

To autostart hass in the virtual environment using ‘source’ in the boot script might not work. To fix this I changed that line to:
. /data/data/com.termux/files/home/hass/bin/activate

  • there is a space between the ‘.’ and the ‘/’

To autostart node-red you might not be able to use the link (node-red) and have to use node to start it:
node /data/data/com.termux/files/usr/lib/node_modules/node-red/red.js

Thanks for making this.

What is the performance of homeassistant on such hardware?

Surprisingly good. Using locally the devices seem to respond quicker than they do via the proper apps.

I have been looking for this to be on any android…Will give it a try again.
Also there is need of time for HA for Android phone which are more powerful then raspberry pi but lack support so that it can be installed using twrp or similar method.

I have tried termux on Redmi 1s, Micromax HS and even on Samsung Galaxy J2…but it fails mostly. But termux is working on Realme 5i, I even loaded Node Red on Realme 5i and it worked great.

Thanks Bro.

i’ve been trying to install following all the instructions (OS RessurectionRemix, android 7.1.2), but im getting many errors during the installation, the first one is when it tries to install cryptography-3.3.2.tar.gz.
when getting to the end, HAss is not installed.
does anyone know what the problem and how to fix it?

1 Like

Thanks for the great work you have done. I installed HA on a Samsung Galaxy Tab S2. First, when I run HA it gets stuck while trying to connect to my TV. It is not frozen bu doesn’t go ahead either. Meanwhile, I can log into HA web page and do preliminary setup, but there is no Supervisor option. Is this because of the package we installed, or being stuck in the middle of identifying entities? Thanks again.

I also encounter a problem, do you know any solution?

1 Like