Home assistant front not refresh (vs code/samba)

Hello,

I’m using samba share (v12.3.0) to be able to modify my configuration directly from vs code (windows 10) everything in the configuration seems to be ok I can access to my dashboard from vscode.

But when I tried for example to modify a title from vscode, I’m not able to get the modification directly on my home assistant front, I tried to reload scene/themes/all yaml configuration but none of them work, but when I restart my rpi the modification is applied in the dashboard.
And if I do the modification on my home assistant front, i have directly the modification in my vscode code.

Is there a way to achieve that, what did i missed ?

Thanks for your help !

Typically, anything that you hack inside .storage only takes effect after a restart.

Mandatory warning: only do manual changes inside .storage if you know what you’re doing.

Oh ok copy that. Maybe I do not use the tool as expected. My purpose was to be able to modify my dashboard from visual studio because there is many tool usefull (intellisense, color, expand/collapse etc) Is there a way to do that directly on visual studio and refresh quickly home assistant ? Because all dashboards are in .storage

You can create pure YAML dashboards, which then reside simply in /config, but then you loose the ability to edit them via UI altogether.

In your configuration.yaml:

lovelace:
  dashboards:
    lovelace-tablet-archos:
      mode: yaml
      filename: lovelace/tablet_archos_dashboard.yaml
      title: Tablet-Archos-yaml
      show_in_sidebar: false
      require_admin: false

Thank you !


I think i will try to work with that because I do not often work with UI except for testing a component

What are you using when you are working on your UI do you work directly on the home assistant front ? (maybe there is some usefull tool that i don’t know)
Or like that directly in YAML ?

Thanks again

I’m using a container installation on some server, so I just use VSCode with a SSH remote connection.

Note that there is a vscode addon as well, running it completely inside your browser, if you fancy that.

Yes I saw the vscode addon, but it’s not compatible with my RPI (i need to upgrade my rpi to a better version)

I will try to take a look at the vs code ssh connection to home assistant, maybe it will be easier to use