Home Assistant interface for Garmin's Connect IQ platform

@alanf When trying to set up through the settings in ConnectIQ, I am unable to change the url within the settings, if i change the field at all I get the error message “Only letters and numbers allowed”. Is there a workaround for this? In fact, this error even applies to the group settings, it wont allow “.” at all.

+1 yes please!

I’m trying to sort this out it’s seem to be not working!

These are my setting and I’m using cloud instead of duckdns

Screenshot_20190929-165236|236x500

Thanks for updating the Garmin app for Fenix 6. Works great!

Hi,

I just installed hassiq on my garmin vivoactive 3 music.
After setting up everything, the connect app prompted me to sign in, but it only loaded a blank page without me being able to complete the sign in process.
Using the long live access token method, I got an error code 1001.

I went through the thread, I did not see any report that is similar to mine. Anything else that I can try?

Hey there! I don’ t know how I screwed setting this up, once I got it running WoW!!

I got it to work with Nabu Casa and a long lived token!!

@kbtang88, did you get this working? If not try deleting the garmin: line in your file, you don’t need the domain, its just a group.

I have deleted that line and still not working

Here is my group config…

image

the group I put into the app config is:
group.watch_devices

I will try that tomorrow

doesn’t work i have put the config that show on there and how about the garmin side?

What is the error you are seeing on the watch?

Thanks for the great work on hassiq. It used to work great for me. Now I tried to set it up again, after the authentication changes and I only get error -300. I’ve read that only https is supported by garmin these days but even when I put in a selfsigned certificate, I still get error -300. Is there anything else I need to configure or is there any way to get some more information about what the problem is?

Is the exact url you are putting into hassiq accessible from your phone?

In the browser it is. In the official android app it only comes up with a blank screen when I’m using ssl, but since it is in very early development I’m thinking this is a different issue. I’m using https://ip:port as the url, if that matters.

I can’t say I have ever tried https with specifying a port in HassIQ. If you could use the default port of 443 and not specify it, that might be worth a try.

Thanks for gettign back to me. I just tried to go with the default port, but everything behaves the same. I tried both https://ip and https://ip:443. It’s reachable in the browser, but the watch comes up with “-300”. Could the certificate be the problem, since it is not trusted?

I had the same issue and solved it by using DuckDNS - so I guess that it is a certificate issue.
See my previous post from jul 9th

Thanks for the info. That doesn’t look good for me. I don’t want to expose my HA to the internet either, but I don’t think my router supports static host entries. At least I can’t find anything like it. Do you by chance know If this is achievable in a different way, if the router doesn’t have the necessary features?

This thread is awesome (and long :face_with_raised_eyebrow:)
Just ordered my vivoactive 4 to track my sleep, stress level and start to run again.
My TomTom is old…need a rest.
I’m a vivid Home Assistant user, and just found out this app was there, thanks Alan!
Can’t wait to fiddle with it, and maybe even support it somehow, I can code a little.

1 Like