Home assistant keeps disconnecting

I run HA on a generic x86-64. So far I haven’t encountered any problems. But now the home assistant keeps disconnecting and reconnecting, once every few minutes (1-2 minutes).

2024-05-16 19:33:54.836 homeassistant systemd[1]: run-docker-runtime\x2drunc-moby-9afe7c4bcc2ab2b9bbdd54d79bbcb36243684ffba7e8ecb10711382e1b7df643-runc.bV34Em.mount: Deactivated successfully.
2024-05-16 19:38:25.851 homeassistant systemd[1]: Starting Cleanup of Temporary Directories...
2024-05-16 19:38:25.904 homeassistant systemd[1]: systemd-tmpfiles-clean.service: Deactivated successfully.
2024-05-16 19:38:25.907 homeassistant systemd[1]: Finished Cleanup of Temporary Directories.
2024-05-16 19:39:56.194 homeassistant systemd[1]: run-docker-runtime\x2drunc-moby-9afe7c4bcc2ab2b9bbdd54d79bbcb36243684ffba7e8ecb10711382e1b7df643-runc.CJy9zA.mount: Deactivated successfully.
2024-05-16 19:42:49.905 homeassistant dockerd[486]: time="2024-05-16T19:42:49.903465350Z" level=error msg="[resolver] failed to query DNS server: 192.168.1.1:53, query: ;o427061.ingest.sentry.io.\tIN\t A" error="read udp 172.30.232.2:60494->192.168.1.1:53: i/o timeout"
2024-05-16 19:46:50.021 homeassistant kernel: audit: type=1334 audit(1715888810.019:231): prog-id=63 op=LOAD
2024-05-16 19:46:50.032 homeassistant systemd[1]: Started Journal Gateway Service.
2024-05-16 19:46:50.040 homeassistant systemd-timesyncd[474]: Network configuration changed, trying to establish connection.
2024-05-16 19:46:50.071 homeassistant systemd-timesyncd[474]: Contacted time server 162.159.200.123:123 (time.cloudflare.com).
2024-05-16 19:51:28.574 homeassistant systemd[1]: run-docker-runtime\x2drunc-moby-9afe7c4bcc2ab2b9bbdd54d79bbcb36243684ffba7e8ecb10711382e1b7df643-runc.kyuBmv.mount: Deactivated successfully.
2024-05-16 19:54:29.226 homeassistant systemd[1]: run-docker-runtime\x2drunc-moby-9afe7c4bcc2ab2b9bbdd54d79bbcb36243684ffba7e8ecb10711382e1b7df643-runc.egXu91.mount: Deactivated successfully.

Home assistant lose connection after this line show’s up
2024-05-16 19:54:29.226 homeassistant systemd[1]: run-docker-runtime\x2drunc-moby-9afe7c4bcc2ab2b9bbdd54d79bbcb36243684ffba7e8ecb10711382e1b7df643-runc.egXu91.mount: Deactivated successfully.

After another connection loss I found this in my supervisor logs
2024-05-16 23:02:50.918 WARNING (sentry-sdk.BackgroundWorker) [urllib3.connectionpool] Retrying (Retry(total=2, connect=None, read=None, redirect=None, status=None)) after connection broken by 'NameResolutionError("<urllib3.connection.HTTPSConnection object at 0x7f31e7e84590>: Failed to resolve 'o427061.ingest.sentry.io' ([Errno -3] Try again)")': /api/5370612/envelope/