Home assistant on docker stopped working, pls help

Tags: #<Tag:0x00007f325ecd4f28>

Hi guys, I installed a home assistant supervi3er in a docker container on an ubuntu machine. It ran very good and restarted properly after reboots. Yesterday there were OS (ubuntu) updates and now I can’t access home assistant. I’m new to docker and cannot pinpoint the problem.

what I tried:
“docker ps” to see if home assistant is running - but docker itself wasn’t running. So I enabled and started the service in systemd. Now docker is running and lists homeassistant like this:

CONTAINER ID        IMAGE                                           COMMAND             CREATED             STATUS              PORTS                  NAMES
53dd9387e92e        homeassistant/home-assistant:stable             "/init"             24 seconds ago      Up 24 seconds                              home-assistant
1c7fd78bf5e6        homeassistant/amd64-hassio-observer:2020.10.1   "/init"             5 weeks ago         Up 11 minutes       0.0.0.0:4357->80/tcp   hassio_observer

but as before all I see when I try to log in is this loading screen:
image

Please help

A bit offtopic, but almost all our machines with docker stopped working last night (December 1st). So that it stopped is probably not your fault.

That’s odd. Let’s see if more people report this problem.

I had the same last night, but after a reboot everything worked fine again.

I think it is an Ubuntu problem. It looks like there was an automatic security update which caused this. You can just start docker with systemctl start docker, you do not need to reboot, but indeed, after a reboot it will work again.

But that does not help the topic starter who has a not working home assistant now.

1 Like

Solved. Thanks for your help. Actually rebooting solved the problem. I haven’t tried it before because I got docker working again without a reboot.

Thanks!

this morning it just pooped, and restarted with mariaDB not autostarting.

Reinstalled the addon and updated the base OS a few times and all’s good.