Home assistant on VM-ware Connection refused after editing secrets.yaml

Hi all…

I’m quite new here but having trouble implementing HA under VMware.

Installation goes normal and everything went fine.
(used the https://www.ivobeerens.nl/2019/01/15/install-home-assistant-hass-io-in-vmware-workstation/ manual)

added hue, sonos and google… Unifi all no problems. (rebooted several time all good).

now i wanted to add Tuya so a added the configuration.yaml and the secrets.yaml
after a reboot i can’t acces my gui (http://192.168.x.x:8123)

i don’t know where i have to start with trouble shooting but i can’t find the configuration.yaml (google saids Usr/share/hassio/homeassistant but i can’t find that folder.

is there anyone who can assist me?

kind regards.
Ingmar.

Do you see anything under
/home/[username]/docker/hassio?

i found the location!!

/mnt/data/supervisor/homeassistant

now i # the Tuya settings and every thing is working again.
except the tuya ofc.

Can you please show the Tuya configuration you tried? And your secrets.yaml (with sensitive information redacted of course).


# Use this file to store secrets like usernames and passwords.
# Learn more at https://home-assistant.io/docs/configuration/secrets/
some_password: welcome


!secret mobilenumber: "0********"
!secret tuyapasword: Password


# Configure a default setup of Home Assistant (frontend, api, etc)
default_config:

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url: example.duckdns.org:8123

# Text to speech
tts:
  - platform: google_translate

zeroconf:


group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

#tuya:
#  username: !secret mobilenumber
#  password: !secret tuyapasword
#  country_code: 31

*NOTE the zeroconfig: i added for trouble shooting

I assume the upper part is the secrets.yaml file?

Remove the !secret at the beginning in secrets.yaml, should look like this:

some_password: welcome

mobilenumber: "0********"
tuyapasword: Password

And the rest should be fine like you have it now.

changed… but after reboot:

The following integrations and platforms could not be set up:

Please check your config.

The integration docs say that the country code needs to be surrounded by quotes.

Do you get any errors under Developer Tools -> Logs?

changed it!!! Logs saids the same!!! *hit myself in the head for not reading the logs…

rebooting now…

still the same error:

Invalid config for [tuya]: [coutry_code] is an invalid option for [tuya]. Check: tuya->tuya->coutry_code.
(See /config/configuration.yaml, line 21). Please check the docs at https://www.home-assistant.io/integrations/tuya

(configuration.yaml)
tuya:
username: !secret mobilenumber
password: !secret tuyapasword
coutry_code: “31”

can’t find example to… only without ’ "

hmm… next error…

2020-02-25 22:58:56 ERROR (SyncWorker_1) [homeassistant.util.yaml.loader] while scanning for the next token
found character ‘' that cannot start any token in "/config/configuration.yaml", line 24, column 17 2020-02-25 22:58:56 ERROR (MainThread) [homeassistant.bootstrap] Failed to parse configuration.yaml: while scanning for the next token found character '’ that cannot start any token
in “/config/configuration.yaml”, line 24, column 17. Activating safe mode
2020-02-25 22:59:03 WARNING (MainThread) [homeassistant.components.hassio.handler] Don’t use ‘server_host’ options with Hass.io
2020-02-25 23:00:15 WARNING (MainThread) [homeassistant.components.webhook] Received message for unregistered webhook da41e198c011c9ef5c4756ded36dd5240371c72206a5cd87166752c0673e7c7a
2020-02-25 23:00:16 WARNING (MainThread) [homeassistant.components.webhook] Received message for unregistered webhook da41e198c011c9ef5c4756ded36dd5240371c72206a5cd87166752c0673e7c7a
2020-02-25 23:04:19 WARNING (MainThread) [homeassistant.components.webhook] Received message for unregistered webhook da41e198c011c9ef5c4756ded36dd5240371c72206a5cd87166752c0673e7c7a
2020-02-25 23:04:20 WARNING (MainThread) [homeassistant.components.webhook] Received message for unregistered webhook da41e198c011c9ef5c4756ded36dd5240371c72206a5cd87166752c0673e7c7a
2020-02-25 23:06:28 WARNING (MainThread) [homeassistant.components.webhook] Received message for unregistered webhook da41e198c011c9ef5c4756ded36dd5240371c72206a5cd87166752c0673e7c7a
2020-02-25 23:06:28 WARNING (MainThread) [homeassistant.components.webhook] Received message for unregistered webhook da41e198c011c9ef5c4756ded36dd5240371c72206a5cd87166752c0673e7c7a
2020-02-25 23:09:26 WARNING (MainThread) [homeassistant.components.webhook] Received message for unregistered webhook da41e198c011c9ef5c4756ded36dd5240371c72206a5cd87166752c0673e7c7a
2020-02-25 23:09:26 WARNING (MainThread) [homeassistant.components.webhook] Received message for unregistered webhook da41e198c011c9ef5c4756ded36dd5240371c72206a5cd87166752c0673e7c7a
2020-02-25 23:14:20 WARNING (MainThread) [homeassistant.components.webhook] Received message for unregistered webhook da41e198c011c9ef5c4756ded36dd5240371c72206a5cd87166752c0673e7c7a
2020-02-25 23:14:21 WARNING (MainThread) [homeassistant.components.webhook] Received message for unregistered webhook da41e198c011c9ef5c4756ded36dd5240371c72206a5cd87166752c0673e7c7a

You wrote coutry_code instead of country_code :wink:

1 Like

i saw… i was working to long trouble shooting!

but that didn’t work.


I have found a solution (for me)

  • I downloaded the Tuya smart Life app.
  • Registered a new account.
  • Added my devices.
  • Changed my username and pw in de secrets.yaml
  • Corrected my typo (Thanks @Burningstone)
  • rebooted…

And it worked!

i guess that the given app didn’t register good to the tuya platforn…?
(the Nedis and LCS apps from the Dutch suppliers.

anyways… Thanks a million @Burningstone for thinking with me…

only to bad that the sensors are not (yet) native supported.

kind regards.

1 Like