Home Assistant runs into recovery mode with error "HTTP option 'server_host'. Watchdog feature disabled"

Hi All
Please help me to solve this issue.

My Home Assistant runs into the recovery mode after upgrade Home Assistant Core 2024.7.0. The full logs is show about server_host configure.

Home Assistant Core
2024-07-04 09:36:52.918 WARNING (MainThread) [homeassistant.components.hassio.handler] Found incompatible HTTP option 'server_host'. Watchdog feature disabled

I searched for a solution to fix it. which found that many suggestions to remove the “server_host” under the “http:” section, but there are no “server_host” in my configuration. So, I just remove all “http:” section. Then restart the Home Assistant , but the system still runs into recovery mode and report the same error log.

Anyone have an ideas for fixing it. Or in my step I took were wrong.

Thank you.

I had the same thing happen to me.
in addition to removing the entire http section from the configuration.yaml file, I also tried stopping several addons at the start as well as nodered but nothing.

I saw through ssh the server_host directive is contained in the config/.storage/http path.

I tried to remove it or let the system to generate a new http file but nothing. This directive is automatically added.

{
  "version": 1,
  "minor_version": 1,
  "key": "http",
  "data": {
    "cors_allowed_origins": [
      "https://cast.home-assistant.io"
    ],
    "server_host": [
      "0.0.0.0",
      "::"
    ],
    "ip_ban_enabled": true,
    "ssl_profile": "modern",
    "server_port": 8123,
    "login_attempts_threshold": -1,
    "use_x_frame_options": true
  }
}

I encountered the same error. Rolled back to backup.

Same error. +1

Same error for me too, no server_host parameter exists in my config.

I resolved my installation by removing the “legacy_api_password” authentication method as this has been removed from HA in this release. (Comment it out/delete it from the yaml config file.

I’ve now successfully upgraded.

3 Likes

Work! Thanks!

it works for me. Thank you.

I had to remove the ‘trusted_networks’ node from configuration.yaml to ‘fix’ the error.

Yup that fixed it

Thank you for this, was banging my head as to what was causing my failure after upgrading to 2024.7. I’m now back in business.