Home Assistant "safe mode" after unsuccessful changes?

Some time ago, I had a big problem with getting Home Asisstant working probably after unsuccessful changes in config or something other.
When I did something, after few days of not using HA, I’ve I found out that my HA is in kinda “safe mode” but not so real safemode cause I didn’t get any info about that but…
Every logs of course did not report anything wrong. All fine.
Energy, Logbook, History, Media browser, Nabucasa settings, all of them just vanished. Cannot log in through Nabu, so it wasn’t only visual vanish but also as service.

After reaching this state of HA, am not able to back and fix them by removing previously made changes. Rebooting Core, Supervisior or even Host (RPi 4B) does not change anything.
Only one way to get it working is recover working backup.

Does someone got something similar? What can cause this kind of behavior of HA. Apart from backups, how can I protect myself from it? What is it causing?


The problem usually comes about from making invalid changes to your YAML.

After every edit you should run the command line config check, which with HAOS is:

ha core check

You do this using one of the SSH add-ons.

If you forget and get into safe mode then your log file will explain the problem, though you can also run the command to find out.

1 Like

Thank you for anwser!
So every time when I’m getting symptoms like disappearing of tabs like Energy, Logbook, History I should just run SSH command which you wrote above and that should fix all of my problems?

No, it won’t fix the problems, but it will tell you what the problems are so that YOU can fix them.


Better still, run the configuration check in the UI every time you touch a YAML file, and again before you restart HA.

Sadly the UI doesn’t catch all the problems, which is why the recommendation is to use the command.


Wow, never knew the UI does anything different from the command. You’d think that would be better documented.

The UI, returns a result within seconds, and isn’t terribly descriptive when there is a problem - esepcially if you are using a split file config.
The shell command, can take several minutes to finish running, and is very descriptive about problems it finds, and specifically which file the problem was found in - even if you are using a split config.

1 Like

Hello again guys,
I’ve same problem again. Tabs which I mentioned earlier vanished. I’m trying to restore backups but it still doesnt work.
Am sure that It worked before I’ve tried to update to latest HA Core. After that am done…

Logs are completly normal, nothing like error.

How to deal with it?