Home Assistant Supervised (previously known as Hass.io) on Synology DSM as native package (not supported or working atm)

Yeah, I found a hack to start it partially going in through ssh… “sudo scripts/start-stop-status start” then they also stopped the usb stuff so I don’t have zigbee now… I found a thread from some people in july using these 3 commands… to get the usb working again on the pre release

/sbin/modprobe usbserial
/sbin/modprobe ftdi_sio
/sbin/modprobe cdc-acm

Sadly still not zigbee. I then tossed up a hail mary and copied over a privilege file from another package so I didn’t have to use the hack to start up the service… didn’t work… got frustrated, wrote a complaint to synology, and then uninstalled. I am no guru at synology or the low level of home assistant… to even docker… I too hope someone gets this going soon. I’m about ready to buy a SBC as right all muy automations in the house are down.

Today I updated to DSM 7
And yes, I can’t repair hassio, but I ran docker container, and all still works, except hassio_dns

Hi @Gio70,
I just installed and it worked.
Do you mean the Supervisor - Dashboard is empty, because that only populates when add-ons are installed or an upgrade is available. The Supervisor - System tab should show you details,

Did you login as the same user local and from outside?

Hi GH2user, thanks for your kindly reply,

I always get the screenshot you posted just if I connect the hassio VM from the external router using OpenVPN, and there I can install add-on and manage everything, but connecting in the lan, I never saw it.

By the way I have another hassio installation within the native package and it’s always correctly populated…I don’t explain to myself!
Login is the same

I want to migrate to VM just for the docker problem since 0.118.5 release, but I’m encountering a new issue…

This is from my smartphone throught Open VPN to my router

I made the jump to Proxmox. So glad I did. Will be running an additional machine now next to my xpenology box (HPN54L) but it is worth it!
Very snappy and really a breeze to setup, create backups etc. I would like to thank @fredrike who made it possible to make the jump from Pi3 to Xpenology 1,5 years ago. Now it is time to move on! For anyone who is interested, I followed this tutorial. Installing Home Assistant using Proxmox. And @BeardedConti see you at your next video! Thanks guys.


First of all thank you for this amazing package!

I recently migrated from Domoticz to this Hassio docker. My DS1512+ did not support deconz, so I replaced it with a DS920+. It has been running stable and I am very happy with it. The recent issues (ignore unhealthy hack, permission issue on DSM7 beta) make me wonder where this is going though. If this is a dead end road, I am left with a few options:

Migrate to the Hassio VM. My DS920+ has the ext4 filesystem, which is not supported by Virtual Machine Manager. In order to get this working I have to delete my 8TB volume, recreate it with btrfs filesystem and restore from backup. A long and risky process.
Alternatively I can utilize the M2 nvme cache disk slots and put a btrfs data volume on it for the VMs. This is unsopported by Synology, so it will void my warranty.

Or I can try to upgrade docker from 18.x to 19.03 via commandline, so I can (maybe?) keep using the Hassio docker version. Again, unsupported by Synology.

To be honost, I don’t like any of these options….

@fredrike, what is your vision on where this is going? Should we wait things out? Do you have intentions to keep supporting this amazing package after the DSM7 upgrade? Or should we start looking for other options?


I too updated to docker 19.03 and now nothing installs, it creates the directory and a usb_devices.txt file and that is it. Is there something I can do to have docker 19.03 and this on my synology

I run the package for 6 month on my Syno 1019+. Since about a week I have massive problems. 2 hours for a restart. and now it is not restaring any more. I tried an clean installation on a Syno 216 II+. But here I get the messages:

20-12-14 06:19:18 WARNING (MainThread) [supervisor.core] System running in a unsupported environment!
20-12-14 06:19:18 CRITICAL (MainThread) [supervisor.core] System running in a unhealthy state and need manual intervention!
20-12-14 06:27:27 WARNING (MainThread) [supervisor.resolution.evaluations.docker_configuration] Docker storage driver btrfs is not supported!
20-12-14 06:27:27 WARNING (MainThread) [supervisor.resolution.evaluations.docker_configuration] Docker logging driver db is not supported!
20-12-14 06:27:27 WARNING (MainThread) [supervisor.resolution.evaluations.base] The configuration of Docker is not supported (more-info: https://www.home-assistant.io/more-info/unsupported/docker_configuration)
20-12-14 06:27:27 WARNING (MainThread) [supervisor.resolution.evaluations.base] Docker version ‘18.09.8’ is not supported by the Supervisor! (more-info: https://www.home-assistant.io/more-info/unsupported/docker_version)

I did no changes only running updates as suggested. I’m not a very exerience user and liked the straight forward method of this package.
Any tips. out there?

These log messages are “normal” because the Synology Docker environment is not officially supported. Do you have any other log messages? Maybe the long restart happens due to a specific integration/device or network/performance issue?

The message “unsupported” is not the problem, the “unhealthy” is it, it is not allowing me to do any updates and the supervisor is not function at all so i can’t install anything.
Did a completely fresh install on the second Syno.
On my “productive” tried various things, but no luck it’s not coming up again.
Funny, the restart had sometimes run very fast, sometimes very slow. This no so good but I can live with that.

Please see the beginning of this thread under “Current Issues”, there is a fix for this message. But if you really did a fresh install and there is no network issue, then it should work.

Weird, if I click on the Supervisor I get a message "unable to load the panel source: /api/hassio/app/entrypoint.js.
I will delete all current files create a new hass.io folder and reinstall the package to see whats happen.

Hello! Has anyone already updated to 2020.12.0 having the fix to ignore the docker version?

Yes, just updated, works fine for me.


Seems I found the problem on my productive Syno. The home-assistant_v2 was corrupt, so I did a new one. Then did the jobs.json thing and now I’m on 2020.12.6. with quite goog restart times. Fingers crossed that it stays stable.

1 Like

If everything goes as planned, I’ll be having new video released this week (Wednesday) covering new installation of hass.io package - until new SynoCommunity package is released, and also how to fix current installation, but as you’ve seen, this was covered here few times already.

EDIT: New video is ready and will be out on Wednesday (16th of December) - here is a link to it https://youtu.be/a01qvvDS7QQ - currently only members can see it as early release perk, but as said, tomorrow will be out for all.


Read #2 post.

The hassio installation on my DS920+ all of a sudden went completely unresponsive today, including all add-ons. The Unifi Addon lost all Access points.

After a restart of the DS, Home Assistant works for about 7 minutes and then looses responsiveness again. In those 7 minutes the memory usage of the Homeassistant docker grows to about 6GB (DS memory usage is then 95%). I tried to clear the supervisor container, and even completely uninstalled the hassio package, deleted the remaining homeassistant container and installed the hassio package again. It did not fix the issue.

Tips are more than welcome…

I doubt the rebooting is normal.

But I am getting the same issue after stopping and getting the clear option working. Did you ever find a fix?