Home Assistant Supervised (previously known as Hass.io) on Synology DSM as native package (not supported or working atm)

when I start those manually, I get this message:
Start container hassio_audio failed: {“message”:"Bind mount failed: ‘/dev/snd’ does not exists

Do you have Audio Station installed?
I still think there is an issue with Docker sockets/API - but it’s above my knowledge on how to debug further.

You can try this one to fix audio

And this too:

7 posts were split to a new topic: Synology Docker and Cast problems

Hi @Tina_De_Feyter. @ashscott and I had a similar issue with the supervisor restarting after about a minute and we found that we needed to uninstall and reinstall the docker package and then the hassio package. We both (hopefully) are running well since, our instructions are up above if you would like to try that as option.

Hi Ezekiel thanks for replying… I have done that several times already… and I keep getting the same message that supervisor is unable to open the page.

Did you try installing Audio Station? HASSIO will not work without this issue solved.

1 Like

I’m running the container without any issues. Must say here that prior installing your package I setup the dedicated hassio docker network via Docker GUI in DSM as per instructions in the community forum. It starts and I really forgot that it exists. I’m running DSM 6.2 on DS216+II

That’s a big relief :slight_smile:


Hi there,

I have a huge smile on my face… I got my supervisor finally running… I do’t know how I did it exactly . All of a sudden it worked. the audiostation was already installed but stopped even after restarting it again the supervisor did not work. then you posted something on the google devices in the meantime and you made reference to firewall! This got me thinking… I added some extra ports and bam all of a sudden this thing worked on a duckdns + let’s encrypt, following your instructions on your youtube. So proud of myself, as I am not an IT-er. Thanks Frederike for this packageand thanks Bearded Thinker for your clear and conscise youtube videos and assistanc on this community platform. Have a great day and Stay Safe!


@BeardedConti Is there something that you want me to add to post #2? Have you managed to find the magics that just fix things (was the red or blue pill)?

Sorry to say, but no.
Most of the things I couldn’t replicate. And all posts and recommendations that you mentioned worked.

1 Like

I’ve managed to get this working on Synology as suggested in the instruction above, Thank you. Do you know where I would put a www folder to add TileBoard files? I cant find the default config folder as suggested by most sites in hassio?

You should put it in …/hass.io/homeassistant folder.

If you used default values, it should be something like:

I have since moved to raspberry pi 4 booting from ssd and I couldn’t be happier. It is much more stable and super fast. I assume the slowdowns I was experiencing on synology was due to the hdd array. My other docker programs running on the synology are much happier now


Thanks, this worked, had to put it in:

1 Like

A post was split to a new topic: USB Booting Rasperry Pi

Is there a direct download link for the SPK? Synocommunity is down for days now… Cheers.

Did you check one of the first posts? There was link to dropbox.
EDIT: Can’t find it - looks like it was removed.

SynoCommunity is upgrading HW and should be up by the end of the weekend if everything goes as planned. There was a post somewhere on Reddit about this.

I found one from the author on March 30th. Just not sure if this is the latest and I already had an installation yesterday.

@fredrike thank you for all your hard work !

I have a DS918 which has two Ethernet ports.

Any pointers on how to get HA to use the second network interface rather than the default primary interface used by the rest of the DSM ?

That’s a interesting idea, would you then look to have your docker running on a separate volume and/or treat it as part of an iot network?