Home Assistant Supervised (previously known as Hass.io) on Synology DSM as native package (not supported or working atm)

for those interested I got the docker monitoring working. :grinning:
Edit /var/packages/Docker/etc/dockerd.json to look similar like this:

   "data-root" : "/var/packages/Docker/target/docker",
   "hosts" : [ "tcp://", "unix:///var/run/docker.sock" ],
   "log-driver" : "db",
   "registry-mirrors" : [],
   "storage-driver" : "btrfs"

Of course you need to use the ip of your diskstation instead of
Do not touch the unix domain socket binding, as the docker ui relies on it!

Source: https://community.synology.com/enu/forum/17/post/107492

1 Like

DSM 6.2.3-25426 is the version.

Hi all, has anyone got the aeotec z wave stick up and running using this package? Mine is arriving tomorrow so any tips or tricks to get it to work would be appreciated. I have the drivers from the first few posts installed ready for tomorrow. I figure I’ll just plug it in and go from there.

Hi all, I’ve inserted the z wave stick and tried the Sudo commands as above and it says the files exist.
I’ve added the zwave integration and now the home assistant docker just continues to reboot every minute over and over. Logs look fine. I can’t maintain stability long enough to load a previous snap shot. Any assistance would be welcome. I really don’t want to uninstall everything and docker again. But if I have to I have too

If I take the USB stick out of the Nas it stops rebooting. Will reboot the nas with the USB stick in and see what happens next

How are people running the native HA on the main IP of their NAS and still adding the Node Red addon with amazon-local? Port 80 is needed for NR and alexa-local.

I read in this thread , but I’m also reading that if you start using compose.yaml you lose the UI simplicity?!?


same problem once I complete the integration of the zwave plugin the home assistant docker container reboots every minute. Is there an issue with adding zwave after the original install ?
@BeardedConti did you put your zwave stick on this package or have you still got your system setup as per your first videos on youtube? I’m thinking i might have to follow your earlier works.

Ok so I have it working.:exploding_head: :tada:
So the addon in hassio hates me. the integration zwave plugin hates me, but if I just yaml the zwave details in the configuration.yaml file, everything works. It’s surviving reboot that I chose to make, and it’s not rebooting it brains out. Ok let’s add some nodes

Sorry if this has been answered or is basic but I have tried to review the thread for an answer and can not find it. I have just setup HA on my 218+ and have it working with many integrations but am having trouble with the USB Zwave/Zigbee stick. Its a HUSBZB-1. I installed the Drivers from the second link but am unsure where to run the commands posted.
“sudo insmod /lib/modules/usbserial.ko
sudo insmod /lib/modules/ftdi_sio.ko”

Does anyone have a link to a walk-through or is able to help me understand this process a bit more.

Thanks in advance,


Ok I think I got it going… For any in my boat the sequence of events is.
1.) Attach USB ZWave/Zigbee Stick.
2.) Install Drivers from link in second post.
3.) Remove and reinsert stick.
4.) Restart HA.
This populated the sticks for me on links dev/ttyUSB0 and dev/ttyUSB1.

@fredrike The current releases of HA appear to have a couple of issues related to Global Cache devices. Both have had recent code updates that needs to be implemented. I have been unable to cross reference the plumbing to match what the git or community pages state to do.

How would one go about updating the code for these two specific issues?

  1. Multiple Configutation Entries for GC100 Devices
    The fix is creating multiple folders in your python directory. This screen shot is from the person who found the resolution and sent to me:

I am unable to find any of that file folder structure in my Synology shared folder. I presume this will be on a different container or perhaps now used in the custom_components folder?!?

  1. There is up update to Global Cache iTach IR sluggish/non-responsive issues that was updated last month which can be found here, its community page. Same plumbing issues as well. I can’t find the path to site-packages dir.



Couldn’t see 1. as the post doesn’t exist…
For 2. - this is hack/workaround - I don’t think that it’s preferred method of fixing/improving things. It can be temporary way of getting things working, but that should be implemented in package not like that.

Thank you for the reply. Strange the first link didnt work. The topic is:
There is an issue with multiple Global Cache GC-100s, and this thread provides a resolution, but again, requires placing additional files in directories.

Can these additional GC-100 py files be added to the custom_components dir?



These files are located inside Docker container @jwbtx - you have to connect to container, and inside container you can change those files.

You can read here about options on how to di it. You still need to transfer file to container. One way is using mapped volumes. And then you simply copy from it to the folder you need file to be located.

The docker exec and docker attach commands allow you to connect to a running container. To get an interactive shell to a container, use the exec command to start a new shell session. The attach command attaches your terminal to a running container.

Be very careful… :wink:

Thank you for the detail!
I’ll read up on connecting to the containers.


Today I accidentally powerd off my Synology NAS where HA was running on Docker. Since I started it again, HA is now running and when looking at Docker on my NAS so is supervisor, but when I click the Supervisor-Tab in my HA Web-UI, it stays empty… also the rest of the sidebar is missing…
HA though is able to control e.g. my lights… But obviously there are some problems with supervisor and Home-Assistant communicating correctly?!?

Here are some logs I got from Docker:




Would be great if anybody who understands then could tell me how to fix the issue! Would be very thankful as I have no idea to get everything running again :slight_smile:

For me it was the classic “Restart your NAS” that solved my problem :wink:

1 Like

Just to make sure - you have only hass.io (supervised version/syno community package) installed, or you also have HA Core (directly in docker).

I have both installed, but only one running at each time. hass.io used homeassistant (no space) name of Docker container, and my other (Core) version is home-assistant. That’s how I’m sure on what’s running.

If you have only hass.io package installed - disregard everything I’ve written, and let’s try another path :slight_smile:

Stop by hand home assistant container. And also stop and start hassio package in package center. And check what’s going on.

EDIT: So you are using just hass.io - try stopping containers by hand and stop/restart hassio Syno Community package. It should work (I hope)

Hass.io on Synology has been working fantastic for me…I have installations on two different Synology NAS. However, I was curious if switching to MariaDB would offer any performance benefits. The downside, of course, is one more thing to manage.

To keep things consistent and portable in the future with snapshots, I would install using the Hass.io Add-on rather than a separate standalone Docker installation on the Synology.

Is it worth the added complexity? Even on my old DS1511+, the last several Home Assistant updates have greatly sped things up, so performance doesn’t seem to be quite the issue it was.

Thanks for any insight!

1 Like

Hey @ryans - I’m using influxDB as separate container in docker for database.
I don’t think that here it’s question of complexity, but question of need. If you are OK with current setup, you really don’t need MariaDB or influxDB or and other/external db.

But what you get from this setup is possibility to store data for longer period of time in more robust environment, that can handle more records. So do you need long term sensor information or stats from entities?

Then again, I could be completely of the track here :smiley:

For the add-ons, is there any way to get the logs from further back?

I have an issue with the Deconz add-on that seems to be sending messages to Node-Red at the early hours of the morning and turning lights on. I can see the timestamps in my Node-Red flows and the only triggers are zigbee buttons around the house. Just trying to trace what is causing the inputs.