Home assistant upgrade to 2022.9 from 2022.7 broke alarmo integration?

Hello, I hope someone can help me with this issue. Nut sure if this is the right forum part.

Today I upgraded my Home assistant core installation as I always do:

sudo -u homeassistant -H -s

source /srv/homeassistant/bin/activate

pip3 install --upgrade homeassistant

I had some problems at first installing:

ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
hass-nabucasa 0.54.1 requires cryptography<37.0,>=2.8, but you have cryptography 37.0.4 which is incompatible.

But several attempts seems to fix this issue. Home assistant is running version 2022.9 now.
But my Alarmo integration, installed with haccs, is not available anymore. Log shows:

Logger: homeassistant.setup
Source: setup.py:192
First occurred: 17:04:40 (1 occurrences)
Last logged: 17:04:40

Setup failed for custom integration alarmo: Unable to import component: No module named 'paho'

I’m running Ubuntu server 22.04 and that’s why I installed:
sudo apt install python3-paho-mqtt

But this does not solve this: Unable to import component: No module named ‘paho’
What do I miss here? It must be something simple. But I do not see what.

Edit:
I just tried to rebuild Home assistant as:

sudo su
systemctl stop [email protected]
cd /srv
mv homeassistant homeassistant_old
mkdir homeassistant
chown homeassistant:homeassistant homeassistant
sudo -u homeassistant -H -s
cd /srv/homeassistant
python3.10 -m venv .
source bin/activate
python3 -m pip install wheel
pip3 install homeassistant
systemctl start [email protected]

To make sure I have a clean install. It took a while to start after that.
But I still have a problem with the alarmo integration looking for paho module.
Anyone knows how to solve?

pip3 install paho-mqtt ?

Yes!! You’re right. That is it. I do not remember I installed paho-mqtt before. But it is working now!
Thanks a lot Andrew.

1 Like

I’ve never used anything but supervised and OS methods, so I’m not sure. But presumably there is a requirements.txt isn’t there?

I had this same issue, and the same fixed worked. Why would I need to install paho-mqtt to fix a problem with a cryptography library being too new?!