Home Assistant URL

Tags: #<Tag:0x00007f73b48fe420>

Can you enter your HA from IOS app yet?

I understand the frustration you are having, even the simplest things sometimes are hard to figure out. As stated above if your on your home network enter http://hassio.local:8123 into the app, be sure to put the http:// before the hassio.local:8123 and hit save. That should do it.

2 Likes

hey all,

I am as new as you can be to the HA stuff and I am just poking around in the dark in order to see what I like and what happens.
I installed the HA on my QNAP and is running (without anything configured - just the home screen) and want to see what the app can do for me.
So I installed the app and activated my VPN on my phone (to login into my home network) and entered the local IP and port as URL and the password.
Should work in theory but doesn’t do anything. It even doesn’t save the entries :frowning: Every time I go back to settings the fields are empty again. (yes I did hit the save button)

Any idea what is going on?

Thanks in advance,
sto

1 Like

@sto.teac did you ever get this sorted? I’m confused why it doesn’t ask for a username, only a password - what password?!

It will be the API password…

The “legacy” API password? I’ve only installed HASS within the last month - does that mean I likely need to enable this password before trying to login with the iOS app?

With the current iOS App, the api password is the only authentication available and auth is mandatory from 0.77 so yes.

Thanks, @DavidFW1960 - I’d love to improve the documentation for others following me…is there a method by which I can do this, do you know? There have been lots of little gotchas with this iOS app so far :slight_smile:

There’s a new version on the way… not too far off now that uses the new auth and tokens.

My router has no nat forwarding. So I need to use https://xxxx.ddns.net while outside of home network and https://xxxx.ddns.net:8123 while inside home wifi network. Is it possible that the app recognizes this automatically and does it automatically? Thanks

edit: I’ve downloaded the beta version and it already does what I need. Thanks.

Thats quite helping

I also am having an issue connecting the Home Assistant iOS app to my server. I’m using v1.1.1 on iOS v9.3.5.

I’ve added these lines to my configuration.yaml file:
http:
api_password:

And I’m using http://:8123 as the url and in the app, but am still getting “The password was incorrect” in the app.

How can I determine what I’m doing wrong?

TIA

My post contained things in angle brackets - they weren’t included in the post. It should have read

http:
api_password: {my password}

and http://{myip}:8123 and {my password} in the app.

Sorry - new to this forum.

I think there is a MAJOR Bug in the iOS App.

First, there are only two textfields for URL and password in the iOS App. - If I try the set password of the only existing user, but it gives me an error, ‘wrong password’. Here I this error belongs on the api compontent, in general the api_password. - Mhh… Where comes that from? What API? I can not find any sections in the documentation, where it says to configure api for iOS.
Nevertheless, I did just wrote ‘api:’ to the configuration as well. And tried it again. Nope, not working.

The second option is to automatic establish the connection per discovery. But even that don’t work.
If I tap on the discovered HA instance, it just removes the passwordfield (Wut) so it only only shows that HA URL as well as the save button. - By the way the save button isn’t working either. It just tells (surprisingly) that the password is missing (or wrong). Data won’t be saved.
The HA log is telling something about bearer-auth. … I don’t find any topic at the docs that would catch this.

So no chance for me to use the app.

PS:
Somehow, someone could also finish to publish the app with identical text in Description as well as in Changelog.

I don’t want to show up as rude, but this can’t be meant serious? How is it possible to drop such bugs?
Did this release got even tested? I mean, it’s the very first step which is necessary to get this app to work, is failing…

You should probably try the new version in public beta now. Public Beta Testing is now open! It is working well.

Just fill in the URL and tap save - it will then prompt for username and password and then 2FA if enabled. Don’t fill in any fields except for the URL

I’m using 1.2.0 version of Home Assistant Companion, installed on iPad 2, iOS 9.3.5

but never get any prompt for username and password and still getting below error:

after click on Done, connection error:

Do you usually specify a port number in the URL? Does it connect properly in a web browser using the same URL?

I’ve found that if you restart the machine running HA while you have your iOS app open, discovery will find the app, and provide the sign-on page (where you enter a user/pass) rather than the initial page (url/pass).

Don’t know if it is supposed to work that way though.

I’m ussing ssl, so it’s port 443, URL address is working internally and externally without any issues on android, windows etc

However on iPad using Safari hass.io never works, as from what I know iOS 9.3.5 is too old and Safari not supporting websockets or something like this :frowning:

Both the app, and Safari were working with HA 0.78.3, but stopped working in 0.79. Nothing that I could see in the release notes suggested any changes in the FrontEnd.