Home Assistant, what is this forum about?

Tags: #<Tag:0x00007f7397a221c0>

Ok im confused. Ive used Google Home device, I have ios programming experience but ive digressed into arduino/rpi tinkerer for the past 2 years. I got as far as wiring up a ble relay board to an rpi2 via gpio pins via an hm10 module. I remember installing an nginx reverse proxy server and creating Google Action that called a webhook that came to my nginx server on the rpi2 and ran a python that toggled the relay for my outside lights. I didnt like it much because internet connectivity is an issue here in my country.

Since then Ive added more things to the ble relay board, moved it over to an rpi3 and Im interested in adding iphone homekit accessibility to be able to control my rpi3 or ble relay board. So I found a couple of articles talking about this homebridge that i can install and run on my rpi, so i resorted to my old rpi2. Ive updated and upgraded apt-get and now Im about to configure homebridge.

My question is, I found this other article that brought me here: https://blog.titansoft.com.sg/2017/06/25/home-automation-with-amazon-echo-google-home-ha-bridge/

So what im beginning to think is that this forum is about the generic topic of home assistants and these bridge software are many that can be used to connect different home assistant technologies from Apple HomeKit to Google Home to Amazon Echo etc?

The forums url is

community (dot) home-assistant.io

Click and ye shall be rewarded with the knowledge :slight_smile:

OOOOoooooohhhh! i hadnt seen that. Originally i found this forum from google groups, so i thought it was the google home assistant forum.

Cool so this is an alternative to homebridge?! Gr8!

Ok so I want to install it but, is there a terminal way to installing it rather than the sd card mess? Im following this link:

Says its for raspberry pi, but it’s basically a mini-tweak or two off any debian-based distro :+1:

It seems like home assistant was the jumping board for Google home assistant.

Anyway, the big question…I’ve already got homebridge installed on my rpi2. I didn’t know about hassio and I wanted my iPhone to connect to my rpi. The reason is that at present I have an RPi connected to a ble relay board controlling 3 test project relays but 1 relay that controls my house lights outside via a simple py script that checks time and based on that turns the lights on or off. However I plan to add a few more things to the house like:

  • garden irrigation
  • water consumption meter
  • pirs for motion detection
  • curtain stepper projects
  • power consumption data

The rpi interfaces with a few Arduinos and I would like the Google home device to interact as well.

It seems that installing hassio on my rpi2 would be better since it’ll let me interface with Google’s api Ai, also I think I saw that I could have it run python scripts on my RPi which would help me control the rpi itself as well instead of just using it as a bridge and I also just saw that I could install homebridge from within hassio! Woah. So wait, do I need to uninstall homebridge before installing hassio?

Just a thought, but you could pop the SD card out of your RPi, flash a new card with hassio, and try it. If not to your liking, just reboot with your original card.

Well yeah I know, ill need an sd card but in the meantime i tried installing using this:

but i still get python 3.4.2 instead of 3.5.3. Why?

You have just installed home assistant in a virtual environment on whatever base system you installed first. If you have python 3.4.2 (which I think is the standard version installed by Raspian Jessie) then that is what you have. If you then install python 3.5.3 then you will have a Raspbian Jessie with Python 3.5.3 on it.

Or you can install Raspbian Stretch which comes with Python 3.5.3 pre-installed.

But if you installed a newer version of Home Assistant on a pre-Stretch Raspbian sytem (without installing Python 3.5) I don’t think that is supposed to work.

Are you saying that you tried to install Home Assistant and it failed?

yes, so i had jessie and python 3.4.2. i updated and upgraded repos, then tried installing python 3 per instructions, and when i got to installing homebridge i got an error saying i needed python 3.5.3.

If you are installing on a fresh SD card the easiest thing to do would be to just install Raspbian Stretch (which come with 3.5.3…I think) and then follow the instructions again to install in a virtual environment.

I’ve upgraded my Python before in Jessie to the new version and it isn’t too hard but if you can avoid all of that by just installing Stretch from the get go then that’s what I would do. And actually that’s what I did when I switched my install from a RPi to a Debian Stretch OS on a NUC.