Home Assistant Won't start Upnp/SSDP server after adding SSL Certificate

Hi Guys,

I am using Home Assistant on virtualbox. I am trying to enable remote access to my home assistant so I install Duckdns add on and add letscrypt encryption and Duckdns Token to generate SSL certificate in SSL folded. I then add the SSL certificate to my Configuration file.
However, after reboot home assistant core is running but I cannot connect to its web interface.
Below is my configuration file

#Loads default set of integrations. Do not remove.

default_config:

#Load frontend themes from the themes folder

frontend:

  themes: !include_dir_merge_named themes

automation: !include automations.yaml

script: !include scripts.yaml

scene: !include scenes.yaml

http:

  ssl_certificate: /ssl/fullchain.pem

  ssl_key: /ssl/privkey.pem

Below is the fault log

2023-07-15 20:53:17.446 WARNING (MainThread) [homeassistant.components.ssdp] Could not set up UPnP/SSDP server, as a presentation URL could not be determined; Please configure your internal URL in the Home Assistant general configuration

my duckdns configuration

domains:
  - domain1.duckdns.org
  - domain2.duckdns.org
token: ****************************************
aliases: []
lets_encrypt:
  accept_terms: true
  algo: secp384r1
  certfile: fullchain.pem
  keyfile: privkey.pem
seconds: 300

I tried to connect using my HTTP://IP address:8123 and homeassistant.local:8123 and not of them work.
If I remove the certificate from the configuration file then it works again.

Can someone let me know what is wrong or what else could I try to get remote connection to work ?

As you enabled SSL, you know have to use https: HTTPS://<IP address>:8123.
The UPnP/SSDP isn’t related to the fact that you cannot access the ui.

Thanks Chris, Tried https and it works, I can now remotely connect and integrate with Google home. You are a legend. :grinning: