Home assistant Yellow installation issues

Just got the full kit with the CM4 included, Status LED is blinking twice (patern) imagine that is the heartbeat for more then an hour, so i tried the Re-install recommanded way, didnt do much more, and now tried the other way still nothing.
any ideas…

If you got the full kit, you shouldn’t have needed to do anything, it was preinstalled.

1 Like

Hey Mark thanks for the link,

I had also same problem and been trying for several days to install home Assisstant Yellow as well.

I got always flickering yellow led even after 20 minutes and kept flickering. After unplugged everything out of my home assisstant yellow. I plugging the power wire back in and holding blue and red button like that for 5 seconds.As described on the website: Home Assistant Yellow Guide

And applied the process back from beginning:

. I put the usb flash back into the drive with Raspberry Pi software
. Internet cable and power cable back into home assisstant Yellow
. After installation, finally only the red led remained on; installation completed

Hope by now everything is working for you!

I’ve put my solution with using M.2 here: Installing on M.2
I hope it would be some help

My issue is that i had to plug it directly in my switch, even if its not the Poe edition it burned 2 of my keystone ethernet ports…
Once i plugged it in the switch everything worked directly.

Hi folks, I’m new to HA. Received my PoE kit with NVMe, and experienced similar issues described here. For many attempts I never once saw the yellow light. Usually just solid red and green. And some times I would get the 4-5 pattern, which translates to ‘fatal firmware error.’ Factory resets seemed to do nothing.

This statement from Mark basically sums up my experience:

I don’t remember what happened that finally got it working, or why it wasn’t working the first few times, I just kept trying.

I was planning to try and reflash the EEPROM, but it is stretching my knowhow.

What I did do was to remove the NVMe (which had been purchased from Seeed wtih the kit). When I did that, I saw the yellow light for the first time (hurray!). But then it was back to just solid red and green. Then I took of the heat sink and reseated the CM4. And after that, still solid red and green. Along the journey I had tried several different Ethernet cables, and a couple of PoE power supplies.

By this point my spirit was officially broken, and I was about to give up… and then it just worked :man_shrugging:

Sorry this isn’t definitive advice on how to solve this issue, but hopefully my experience helps someone navigate any issues they experience. Maybe you just need to be willing to get to the absolute end of your tether before computer says yes! :smiley:

1 Like

As DNS-Sec is used by home-assistant.io domain. Its important that the time on the Yellow is correct, otherwise the install will not work, and you will see the following like errors if you access the yellow’s console:

# ping version.home-assistant.io
ping: bad address 'version.home-assistant.io'

# curl --no-progress-meter -L https://version.home-assistant.io/stable.json
curl: (6) Could not resolve host: version.home-assistant.io

# systemd-resolve version.home-assistant.io
version.home-assistant.io: resolve call failed: DNSSEC validation failed: signature-expired

The above message is misleading, as the signature start time is in the future.

How to confirm its a time error:

  • The TZ is optional, check the year and month
# TZ=Australia/Melbourne date
Tue Dec 20 20:09:05 AEDT 2022

I suspect this is the date it was tested, it took 18 months for my CM4 to arrive.

  • See what Time Server your using
# networkctl stats
        State: routable
  Online state: online
       Address: on end0
                2001:4479:6903:7a00:da2a:ddff:fecd:18ab on end0
                fe80::da3a:ddff:fecd:18ab on end0
       Gateway: on end0
                fe80::c225:6ff:fedc:adfc on end0
# timedatectl show-timesync --all
PollIntervalMaxUSec=34min 8s
PollIntervalUSec=34min 8s

The NTP (Time Server information comes from your DHCP server), check IP address indicated is infact running a time service, link ntpd, or chrony or its the same IP address as your modem/router as most run a time service.

Fix your DHCP server so it responds with a valid time server IP address. And then reboot or run the following:

# networkctl forcerenew end0
# systemctl restart systemd-networkd.service
# TZ=Australia/Melbourne date

It would be nice if the yellow installer had a python web server which ran the install, instead of
/usr/bin/haos-flash which is called by systemd service install-autostart

The issue can also happen if you are using https and the date on the system is earlier than the start date of the SSL/TSL certificate.

The cost me a fair about of time to determine the cause was the NTP setting sent by the DHCP server was invalid. I hope posting here saves others some time. You can access the console by plugging a cable into the USB-C, see use-serial-console-windows or use-serial-console-linux-macos for more details.