Home assistant yellow USB A not working

Hello,

I just received a new HA Yellow. When trying to connect my zigbee dongle or whatever other USB componrnt to any of the USB 2.0 Type-A Host ports, nothing seems to work.

An USB memory stick is even not flashing a LED, seems the ports have no power at all.

What am I missing ?

Sorry I don’t have an answer for you. I just ordered a HA Yellow myself and now, of course, and wondering why this might have happened. Did you find a solution?

No solution yet, I bought a powered USB hub as possible the power consumption of the Skyconnect & the RS485 converter was too high, unlikely as they where / are working fine on my good old Raspberry pi 4.
No solution as still no USB device being detected.

I contacted the vendor, lets’s see what the feedback is from them, may be I just had bad luck with this device

I had to send the yellow back, seems to have been a hardware malfunction. Case closed

1 Like

I had the same problem trying to install a Z-wave stick.
I found the USB did not seem to be powered, the stick has a LED indicator and it would not light when inserted.
But insert it, power cycle the yellow and it seems to detect the USB and power it.
Problem solved.

So I’ve had a HA Yellow for a couple of years and the USB ports seem to have gone kaput. I had a power outage (multiple in a row, on-off, probably power surges, too) and after my ZWave and Matter integrations stopped working. Power cycled the Yellow several times, no good. First I thought it was the dongles, but they show up with lsusb on another system, but on the HA Yellow nothing, also no power lights. I’m hoping it’s just the carrier board and I can migrate the Pi4 module to another machine. In the meantime I’m migrating my HA install to a NUC - fortunately everything else seems to work except the USB ports.

Edit: I’m still going to migrate to a NUC for other reasons, but afterwards I’ll see if I can get to the bottom of this. I seem to recall the Yellow had a special mode on its USB ports for programming, maybe it got set into that mode somehow.

My Yellow has needed shutdown/poweroff/wait/poweron cycles before, for about a year, to bring back the ZWave every once in a while. At the time I thought it was the dongle. But it could well have been the USB ports flaking out.