HomeAssistant and Reolink Doorbell POE

For anyone who’s interested, here is the Automation I’ve created for my Reolink doorbell.

When someone presses the bell, it does 3 things (in parallel, so that each occur as quickly as possible):

  • Notification to my phone via the Companion app (I use Android, might need minor tweaks for iOS)
  • Toast message on my LG TV
  • Starts a Routine on my Alexa devices (I use Routines as I found this is easier to modify the target Echo device(s) when I add any more via the Alexa app)
alias: Front Door Bell Pressed
description: "Provides various notifications when the Reolink doorbell button is pressed"
  - type: turned_on
    platform: device
    device_id: [redacted]
    entity_id: binary_sensor.front_door_visitor
    domain: binary_sensor
condition: []
  - parallel:
      - service: notify.mobile_app_garry_phone
          message: Someone is at the front door
            image: /api/camera_proxy/camera.front_door_snapshots
            ttl: 0
            priority: high
      - service: media_player.play_media
          entity_id: media_player.lounge_echo_dot
          media_content_id: someone is at the front door
          media_content_type: routine
        metadata: {}
        enabled: true
      - service: notify.lg_lounge
          message: Someone is at the front door
        enabled: true
mode: single


Same here. I kept asking and they kept saying no.

Mine is the WiFi doorbell, build date is 23010901. and it advertises two way talk but I have not gotten the doorbell to output audio yet, unsure of if it is finished being implemented yet

I asked due to RTSP issues I was having, I did not ask for it for backchannel audio, that just happened to be a nice easter egg

I am on firmware
Reolink Video Doorbell PoE
Firmware: v3.0.0.1459_22102808

But there is no update available in the app, in the doorbell or on the download section of reolink.

Any one able to help out where to get the latest firmware?

I use the HACS integration (17 entities) because the “original” integration does only provide 7 entities.
And both do nothing on the binary_sensor.reolink_video_doorbell_visitor entity. No response on that entity.

You must be able to access HA via regular http if you want visitor entity to work. There is something wrong with ONVIF and https. Sorry I can’t give more details at the moment. But it should be enough to get you started searching the HA community:)

Thank you, I found this and it works:

This is wrong:


Running firmware:

All works well but the the button press is not detected with above settings.

A person detected does not work then either:

this SOLVES my issue:

Glad it worked, i can’t access my HA on regular http port 80 either so I have the same setup with 8123.

Just got my doorbell installed (WiFi) and am having similar issues with the visitor sensor not updating. I am currently running my HA through a reverse proxy so I use https even on my LAN.
I’m not super familiar with ONVIF or the events that go along with it but it seems like this is a bug with the event not being sent to https links? is this correct?
Would this be resolved by a firmware update? My current version is v3.0.0.1459_22102806

EDIT: I have updated my internal HA url to be http and it seems to resolve the issue but I would prefer to not have to do this.

I have the same Problem as many others:

I cant see a stream on the Google nest hub, when it was send through HA.
Even on the dashboard it is Not working.

At the PC or in the mobile App, everything works. But no casting to the nest hub.

Then write reolink to have them change it. I have done that as well.

1 Like

Small question. I just installed my Reolink doorbell and tried to integrate this in HA.
HA can interact with the doorbell but the “notifications” for movement, people and visitor are not working.
(I changed the local network setting like mentioned earlier in this post)
Can it be that this is not working when HA and the doorbell are in different subnets? (they are in different VLANs)

Homeassitant must be accessible via http, than it works. It’s discussed in detail in this ticket: Reolink integration not showing doorbell notification for Reolink Doorbell · Issue #87134 · home-assistant/core · GitHub

1 Like

Can anyone give any advice as to a suitable PoE switch that can be used for this doorbell? I’m trying to find the PoE standard that the doorbell uses, as the Reolink site says it can either be powered by PoE, using a 12-24v AC or 24v DC supply from a power adapter or existing doorbell wiring. The 8 port switches I’ve found online have 48v output, which I believe are the PoE+ versions for higher powered devices (802.3at?)

I have a 8 port POE switch from tp-link, But any POE switch should do, they are backwards compatible, you can also get a general POE injector.

1 Like

My Zyxel GS1900-8HP also powers it just fine

What video settings are you using? I’m testing Scrypted to Homekit with my RLC-420, which has two streams:

  • Main: 2560x1920
  • Sub: 640x480

Regardless of whether I use the Reolink plugin in Scrypted or the ONVIF plugin, only the Sub stream works reliably (but with disappointing video quality). Using the main stream is super choppy with HKSV with lots of dropped frames. Does the doorbell have a 1920x1800ish size stream that works better w/ HKSV? I’m thinking of getting the doorbell, but wouldn’t want to be stuck w/ 640x480 quality in Homekit.

Also, would appreciate any suggestions on settings I could change to improve my current RLC-420 setup with homekit using higher res video.

Thank you!

I had to contact support to get a newer firmware which fixed the awful rtsp realization

A new Reolink POE doorbell firmware has dropped,
Downloadable from their site :slight_smile: release notes dont indicate anything with http/https :frowning: so that is a bit of a bummer

1 Like

Yes a better description is available here:

I was very excited about the two-way-audio support using ONVIF, but it’s not working for me :’(