Homeassistant Yellow with Z2M Problems with Serial

Hello all,

I just can not get Z2M to run with the HA Yellow :frowning:
The port is /dev/ttyAMA1, I have specified it correctly, but I get this error all the time:

Zigbee2MQTT:error 2022-10-24 10:45:36: Exiting...
Zigbee2MQTT:error 2022-10-24 10:45:36: Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms)
    at ZStackAdapter.start (/app/node_modules/zigbe`Preformatted text`e-herdsman/src/adapter/z-stack/adapter/zStackAdapter.ts:103:27)
    at Controller.start (/app/node_modules/zigbee-herdsman/src/controller/controller.ts:132:29)
    at Zigbee.start (/app/lib/zigbee.ts:58:27)
    at Controller.start (/app/lib/controller.ts:101:27)
    at start (/app/index.js:109:5)

I just saw the following in the Supervisor Log:

22-10-24 10:35:27 ERROR (MainThread) [supervisor.utils.dbus] D-Bus method org.freedesktop.DBus.Properties.call_get_all not exists!
22-10-24 10:35:27 WARNING (MainThread) [supervisor.dbus.network] Can't process /org/freedesktop/NetworkManager/Devices/58: 
This is my config for Z2M:

homeassistant:
  legacy_entity_attributes: true
  status_topic: homeassistant/status
permit_join: false
frontend:
  port: 8099
data_path: /config/zigbee2mqtt
devices: devices.yaml
mqtt:
  base_topic: zigbee2mqtt
  server: mqtt://xxxxxxxx:1883
  keepalive: 60
  reject_unauthorized: false
  version: 4
  user: xxxxxxxx
  password: xxxxxxxx
  client_id: zigbee2mqtt
  include_device_information: true
serial:
  port: /dev/ttyAMA1

I hope you can help me guys!

Thanks!

try adding

adapter: ezsp

below
serial:
port: /dev/ttyAMA1

It seems, its trying to connect to the wrong adapter (zstack)

Hello,

I’m with the same problem. Yellow can’t access to device AMA1. If I connect my Sonoff Zigbee3 antenna to yellow and set the port to USB0 works, otherwise not.

I also tried with a factory default configuration, only changing ACM0 to AMA1 with the same result

Thanks in advance

If you want to use Z2M (like I do), then put that under the serial as well:
adapter: ezsp
Then it works.

However, I now have the problem that the zHA integration constantly reports and wants to be installed :confused:

1 Like

Sorry have fully forgotten to answer!
Dude you made my day :)!

You do not happen to know how I disable the Zha integration permanently?