Homegear and max! cube alterative

Hi,
I have flashed eq-max! cube with cul-cun firmware. It all worked superb until about 2 months ago. Then I try to make clean install but now I can not make homegear work at all.

Is there any alternative for homegear? Or maybe some other getway that work with max! thermostats?

Does this have anything to do with home assistant?

I have had issues with homegear and wanted an alternative as well, the only I found is this software : http://www.dmitry-kazakov.de/ada/max_home_automation.htm
However, I’m not sure it works with a flashed cube.
Other than this, I ran out of options.

Which version of homegear are you using and what is the issue?

Hi.

Problem is that I can find usb device via ssh like this:
find%20usb%20device

Then I have try to install many hassio addons that have homegear:
like this from creativemonkey

or this one

And when I try to install homegear i get this reply.

19-08-04 09:35:27 ERROR (SyncWorker_0) [hassio.docker] Can't start addon_69c7aa1d_homegear: 500 Server Error: Internal Server Error ("linux runtime spec devices: error gathering device information while adding custom device "/dev/ttyUSB0": no such file or directory")

For that reason i try to install my own homegear that does not want ttyUSB0 (I will use LAN interface anyway)

And change max config in homegear folder to this

## The device family this interface is for
[CUNX]

## Specify an unique id here to identify this device in Homegear
id = My-CUNX

## When default is set to "true" Homegear will assign this device
## to new peers.
default = true

## Options: cul, cc1100, coc, cunx, hmcfglan, hmlgw
deviceType = cunx

## IP address of your CUNX
host = 192.168.1.128

## Port number your CUNX listens on. Normally 2323.
port = 2323

## Default: responseDelay = 95
## Should be "40" for CUNX
responseDelay = 40

And when i try to start up it stay at this log

08/04/19 12:09:33.607 Git commit SHA of libhomegear-base: -
08/04/19 12:09:33.607 Git branch of libhomegear-base:     -
08/04/19 12:09:33.607 Git commit SHA of Homegear:         -
08/04/19 12:09:33.607 Git branch of Homegear:             -
08/04/19 12:09:33.607 Determining maximum thread count...

And now i can not connect to web ui of homegear via ipaddr:2000 or ipaddres:2001
even can not connect to homegear vi homegear manager

Which version of homegear are you trying to install? Is it an install with docker?
I have the same issue with nightlies in docker, but it works with the stable version

I am trying to install this addon.

I do not know how to install docker :confused:

Docker is included with hassio, no need to install it.

Is there any guide how to install homegear into docker on hassio? I am so sorry but I never work with docker

The same way as you install any addon, read the instructions! Start here.

1 Like

I have now try to install homegear to other rPI, i can manage to install and start it. I can also add gatway to homegear. But when I try to pair thermostat, on thermostat show that connection is succesfuly but on homegear I can not see and device

I am sorry I forgot to poast the link in my last post . Sart here https://www.home-assistant.io/hassio/

This is NOT the homegear forum. We don’t mind helping you install an addon in hassio, but the mechanics of homegear itself is off topic.