HomeKit can't connect to HA running in docker on Synology using a VPN

I’ve been struggling with this issue for days now…
Any help would be greatly appreciated.

I’m running HA in docker on a Synology NAS.

I can pair HA with HomeKit (to control HomeKit with siri commands) and it works fine…but only if my VPN on the Synology off.

Now, for privacy reasons, I want the VPN on the Synology to be always on.

The VPN is definitely the part that is screwing things up.

It should be possible though, because when I run HomeBridge in docker on the same system it works just fine with the VPN on.

I’ve tried to configure the HomeKit integration with the UI, with Yaml, I’ve tried advertise_ip and turned zeroconf default_interface off…

Nothing helped.

Until I turn off my VPN…

Help? :slight_smile:

Did you find solution?
After update to 2021.5.0 get same error.
Raspbian + HA in Docker + OpenVPN client to server, when OpenVPN connected - devices in Homekit Integration “No Response”, Bonjour Browser doesn’t see Bridge. If shutdown vpn client - everything okay. On this raspberry working Homebrdige - everything ok with it vpn connected or not.

Unfortunately, I haven’t found a solution… :frowning:

Tried this configuration, now it works, don’t know how long it will do.

zeroconf:
    default_interface: false
  
homekit:
  name: "HABridge"
  ip_address: 192.168.0.88
  advertise_ip: 192.168.0.88

I’m added advertise_ip, and change zeroconf default_interface, I think promblem was here.

Ok so I have found a solution for Synology - Portainer/Docker - HA.

Follow Docker Networking Tutorial // ALL Network Types explained! - YouTube “MacvLan” network creation in docker for HA.
This also works for Portainer.
Make sure it is on a different Ethernet port than your primary NAS/Docker containers as the MacVlan network is not allowed to see any other traffic from the Ethernet interface it is setup on.
Remove the HA container from the current network and add the MacVvlan configuration network.

Set you new IP address in the Configuration yaml. Restart the container and boom :wink:

homekit:
  ip_address: your.new.macvlan.ip

Do you run in network mode host or bridge?
And what IP is 192.168.0.88? Your Synology NAS? Docker Container IP?

I stuck on the same problem

Edit: Changing the default Network unter Networksettings in Homeassistant to the Ethernet instead of VPN helps me

Thx

This thread was started three years ago - the information in it may be out of date. If possible, start a new thread, with a link to this one to provide context if necessary.

Network mode host. IP - 192.168.0.88 - my raspberry host IP address.