Homekit Controller & Homekit Component


#1

In the HomeKit controller docs it mentions:

Note that HomeKit accessories can only be paired to one device at once. If your device is currently paired with Siri, you will need to reset it in order to pair it with Home Assistant. Once Home Assistant is configured to work with the device, you can export it back to Siri with the HomeKit component.

I have both pieces of this working. I have some HA accessories exposed to Homekit and usable in the Home app. I have some HomeKit accessories exposed to HA and usable.
The problem I’m having is getting HomeKit accessories, which are working with HA, to then also be exposed back to Homekit for use in the Home app.

Example:
Switch 1 (HA MQTT)
Switch 2 (HA HomeKit)

Both switches work in HA.

Switch 1 shows up in the Home app, but Switch 2 does not.

I have my HomeKit component set up to start with a delay (to wait for the zwave network to come up). I believe this should also be providing ample time for the HomeKit controller to get set up and expose the devices.

config:

discovery:
  enable:
    - homekit

homekit:
  auto_start: False
  filter:
    include_domains:
      - alarm_control_panel
      - switch

Any suggestions for debugging this?


#2

@Jon123 You could enable debug logging for both, but I’m not sure how far you can go with it. It seems like your delay is too short so the homekit component can’t add it.

logger:
  logs:
    homeassistant.components.homekit: debug
    homeassistant.components.homekit_controller: debug

#3

That did it. I updated my automation for starting the homekit component to start 1 minute after the z-wave network came up:

- id: "homekit-starter"
  alias: 'Start HomeKit'
  trigger:
    - platform: event
      event_type: zwave.network_ready
  action:
    - delay: 00:01
    - service: homekit.start

Now all the Homekit devices added to HA show up in the Home app. Thanks!


#4

@Jon123 do you still have this working? I want to do just this, but am having some issues.


#5

Yes, but admittedly I’m also very very behind on updating HA. Still on 0.73. Haven’t had the time to dedicate to do the update given all the breaking changes that have happened since then - need to put aside a few hours to deal with it.


#6

I have the same problem, but I dont have any z wave units.
Did you put this into the automations file?
Whad did you put into the configuration file?


#7

This is the automation: Homekit Controller & Homekit Component

The config is in the first post: Homekit Controller & Homekit Component

If you’re not waiting on zwave, it may be some other problem. But you should still be able to delay the homekit starting up, just change the automation’s trigger to:
trigger:

    - platform: homeassistant
      event: start

(I haven’t tested this)