HomeKit error "User input malformed"

Thanks for opening the issue. If anyone has replication steps, please post them to the issue. :+1:

1 Like

Eagerly awaiting a fix for this.

Also having this issue. Going to try deleting my HK integration and adding it again.

The fix has already been tested and posted on GitHub. No need deleting everything when an update is right around the corner ツ.

1 Like

Whoops! Too late. LOL

Hey guys! Release 2021.11.5 is out with the fix.
Not tested yet.


I updated to 2021.11.5 and still have this issue. The interesting thing is, I have two bridges, one with all switches and binary status, and a second that only has a door lock. There is only one entity in the second bridge. Despite me not excluding anything from the second bridge I still get the error of “User input malformed”.
Note: I have not deleted and recreated the Bridge as was told it should not be necessary from an above comment.


I just updated and it fixed the issue for me. Thanks!

Odd, 2021.11.5 update isn’t even showing as available to me yet.

@mike1627 I am running in a venv so when I ran the update it automatically pulled the new version.

@mike1627 same for me.
I’m running Home Assistant OS on my Raspberry PI4… and no update is available.

You can update HA core to a specific version via SSH :wink:

Just confirming that the update worked for me

1 Like

I opened a PR to improve the error message so we can try to track down the cause

Looks like we need to adjust the exclude path as well:


+1 confirmed the fix work on 11.5

1 Like

Just updated to 2021.11.5 and the bug’s still there.


The same for me. In 2021-11-5 the bug is still present


Yep, bug still exists on core2021.11.5


Same here, 2021.11.5.


The same Here.


Issue still there.