Homekit Infused (HKI) v2.0.0 Release Candidate (Beta 11) - Updated 31/05/2020

Tags: #<Tag:0x00007f7399612858>

yes that was perfect thank you so much :smiley: also made me need to learn picture-elements :smiley: guess that will be usefull later when doing a floorplan =)

1 Like

Well thank you, because of your question I have found errors in that card. Haha. Well good luck and don’t forget to join our discord channel (see link in first post).

kind of been out of the loop for awhile, but just noticed my pop-ups don’t open the card anymore, just a blank pop-up on safari and iOS, but seems to work on chrome (desktop only)… still on v1 but did I miss something breaking the cards? (mostly dbuits and the ones you modified previously I believe)

It kinda depends on how long “out of the loop” is haha. It hasn’t been updated in a while so I did not make any changes there. However when this card first emerged it did change quite a lot so yeah that might be the problem. It did break as far as I know and you might need to check the code for changes.

Release Candidate of HKI 2.0.0 (Beta 11)

Changes:

  • HKI is now fully compatible with HA 0.110.x
  • Revised French, Romanian, Italian, Hebrew and Spanish language (this adds vacuum and cover translations, English and Dutch are already available, more languages will follow)
  • Added Polish language (thanks to @donhimol)
  • Fixed bug where changing the language would not reset the attached input_boolean after an error
  • Fixed bug where changing the icon set would not reset the attached input_boolean after an error
  • Fixed bug where the header and/or header subtitle could not be hidden.
  • Added missing header boolean for the covers view.
  • Added cover switch popup
  • Fans on the climate view now show a spinning icon when turned on and now shows a blue color
  • Media Player widget is now an option (fill in the media_players in the room config), this is currently limited to simple media players, I will add functionality to this in upcoming versions.
  • A Google Home widget is now added to the media player view
  • Custom Header has been fixed (please update it via HACS and clear cache). You can now set HKI to be your main dashboard again. As a result the workaround has been removed!
  • Storage mode is now included, the default dashboard and you can create your own dashboards with the Home Assistant interface just like you would without HKI. To have HKI as your main dashboard go to the sidebar and select the preferred dashboard, which is user based.
  • New users that have created an entire dashboard with the lovelace UI editor will be pleased to know that installing HKI will not overwrite anything, nor will you lose access to that dashboard.
  • As a result of the above resources are no longer included in the HKI package, you will have to install them yourself through HACS. After installing an addon it will ask you to add the resources automatically. If you have already installed the addons all you would need to do is add the resources (I suggest you keep the current resource file as a backup which can be found in dashboards/resources as you can quickly copy/paste it into the UI that way). To add resources to Home Assistant go to the Home Assistant Configuration menu and select Lovelace Dashboards. There will then be a tab that says Resources.
  • Your own resources can now be used and will not be overwritten by HKI updates.
  • Fixed an issue where badges on buttons would not update after a change.
  • The Room Config settings will now only show config for the amount of rooms selected per floor (this to avoid rooms not being loaded at startup, please check the room config and add/change your settings if needed)
  • You can now select the amount of floors shown in the lights and devices view. Invoke edit mode to change how it looks or hide it entirely.
  • All groups in HKI Settings > Room Config are now working. The views will no longer get its entities from device_counters.yaml. This file is still needed for counting the number of devices that are ‘on’ so you won’t need to make any changes here. This will also pave the way for a room based view which is highly requested. Make sure you fill in all the blanks in room config and add your cameras in the new camera config view. Remember, your config will no longer come from the extra_settings.yaml file and you MUST fill in the HKI Settings > Room Config for the views to work properly.
  • HKI Settings has 2 new options: Google Home and Cameras
  • Border radius has returned to the theme settings view and can now be set in the ui again. You can safely remove user_content/theme_settings/border-radius.yaml. To use the variable border-radius inside of your custom cards use the following style variable: `border-radius: {{ states(‘input_select.border_radius_selector’) }};
  • Fixed missing custom buttons (the settings would say there are 8 buttons to configure, but 3 were missing)
  • Bugfixes and small enhancements to the code. Cleaned up some of the unused includes.

For more information on how to install/update please visit the link below.

1 Like

There is an error in the latest beta, please remove /dashboards/homekit-infused/remote.yaml to fix it

So just finally got around to looking into this, not sure if you remember how the old pop-ups were setup but it was vertical-stack, swipe-card, entities, pop-up… just removing that first vertical stack it’s all good again. Must have been one of the front-end changes made recently. Thanks!

EDIT: (The old vertical stack was probably from the original pop-up from before Dbuits card…)

1 Like

what should be done, if i am doing it for first time.
how to configure?
thanks

1 Like

Do you plan to make the code lighter so HKI would run on RPi?

I will definitely try to make it lighter, but in its current state this will never run smooth on a rpi (the reason for this is pretty simple: it uses a lot of input text entities which weigh heavy on the backend side).

The project was never made with a pi in mind simply because they are too weak imho (anyone that has used a pi and switched to something better will probably acknowledge this). The main reason it is so heavy is because everything done inside HKI is instant (e.g. adding a light to the frontend will not require a restart, nor will you need to add the light to a group in yaml) this is true for almost every setting within HKI. All changes are always instant and you could even open 2 browser windows to see it change in realtime.

Removing this heavy form of templating will make it lighter though would also make it harder to configure (like 1.1 and 0.13.3 was) it would then also require restarts after most of the changes whereas now you could leave it running forever (unless you really have to add something like automations and such).

The goal of this project was to make something simple to setup but most of all even simpler to use. I am improving the projects code but it might take a while to slim down 60k lines of code. Also I wanted to mention that if people are serious about smart homes that they should not run it on a pi (that is my own personal opinion ofc). As that little machine is the heart and brains of your smarthome. I see it often that people spend hundreds if not thousands of euros on smarthome products but only spend 50 euros on the most important piece. It feels like driving a ferrari with an opel kadett engine or running a GTX2080ti on a pentium 4 (if you get what I mean).

In other news though, I am currently learning to create Android apps and maybe in the future I will create a native app for HKI instead (which would definitely run on a rpi as the serving side).

1 Like

This is awesome, thank you for sharing your work!

Im just getting started and have a few questions I havent been able to find answers too…

  • I am currently using Home Assistant Supervised in docker, It is at 111.4, I see in the instructtions to use 110.4, how can I downgrade to 110.4?

  • Ive filled out the device_counters yaml so far, when I move to config rooms I select 1 floor 9 rooms, but then it looks like it starts at “room 11”? Also, can I add more than one entity per line? So for lights can I put ‘light.living_room_lights, light.strips’ for example? (see image below)

  • The home page shows me an error for the swipe card, Ive verified its installed and loaded in lovelace, even reinstalled it. It looks from the error like maybe i need to add more config? (see image below)

Thanks!

You don’t need to downgrade your HA as you are using the beta of 2.0.0 which is compatible with 0.111.4.

So for the first card you will have to have at least 1 notification. You can create (or uncomment one of the examples) a notification in user_content/notifications.yaml. After doing that you will have to reload lovelace (there are 3 ways to do this, which I will explain all three below).

  1. Go to the HA menu (found inside of the HKI menu at the bottom next to the HKI Settings and About buttons). Once there, press reload lovelace (confirm) and wait. Note this can take up to 30 seconds!
  2. Restart HA (this will always trigger a lovelace refresh)
  3. After making any change in YAML you can also save the homekit-infused.yaml file and then refresh the browser. (you will have to save the mentioned file even if you did NOT make any changes to that file)

Personally I use method 3 as this is the most quick and most visual way.

As for the photo, make sure you have a person entity (you can create one in the HA configuration). Also link any device tracker to your person entity. If you use the official HA app (iOS or Android) you will have a device_tracker already and you can add that to your person. Finally after creating the person entity you will need to add that to the HKI Config > Person Config. Also the error seems to be related to not having a travel to work entity. You can simply create one by using the waze sensor (which is already in core HA). Config would look a bit like this:

sensor:
  - platform: waze_travel_time
    name: Time to Home Darbos
    origin: person.darbos
    destination: zone.home
    region: EU

  - platform: waze_travel_time
    name: Time to Work Darbos
    origin: person.darbos
    destination: zone.work
    region: EU

You can create the corresponding zones within the HA interface (just click on the map and then on the edit button at the top right)

Rooms are numbered by floor number and then room number. Room 11 simply means floor 1 room 1. Room 21 would mean floor 2 room 1. And yes you should use a comma to add more entities on a single row.

Let me know if you need any more help, note that you can also join our discord server (find the link in the first post). This will get you help a lot faster.

Your awesome, thank you for taking the time to walk me through that. Its all working nice now!

I went through and edited the notifications.yaml you mentioned and that cleared up the swipe issue right away.

Then after adding the waze travel time sensors my picture came to life.

And that makes sense now about the rooms, I appreciate you clearing all of this up!

Now time to configure away, this is simply amazing. Thank you sir!

1 Like

Hey couple more questions. I’m missing something simple I know it.

  • on the lighting page where do I add the entities that should show up here? I’ve filled in the device counters and that works but can’t find where to list lights in this page. I see the empty lights user content yaml but I was hoping to get buttons the same as used throughout the setup.

  • how do I change the time to work to something else? Pic below.

  • when editing a page I see the turn on off certain domains but not sure where to fill them in? Pic below.

I just thought of something I haven’t filled out customize.yaml yet. I’ll try adding entities there and maybe that’s what I’m missing

Thanks again.

Adding to customize didn’t help. Where do you add the devices to like the lighting page?

For this you will have to fill out the room config and then enable them on the specific views.

Fill in the entities above. Note that all empty spaces MUST have an entity. If you don’t have this already you can simply press the reset button at the top of that page. Press update for each line when done. To add multiple entities separate them with a comma. light.lamp, light.lamp2

device_counters.yaml only does… well what the name implies, count devices :stuck_out_tongue:

Lol. Thanks for the quick help bud. I assumed that about the counters:) I’ll work on that next thank you again!!!

Alright, I need to bug ya one more time. I dont know why Im running into this issue, I normally use yaml to configure lovelace so you think this would be easier for me lol.

I filled in a few rooms, about 4 or 5 rooms and I ticked the show in devices and show in lighting booleans for each room. However I still get nothing in devices or lighting…see pic below of room config example for 1 room.

I pasted some screenshots of errors Im seeing in the chrome inspector…I verified I have the cards installed it complains about, and I show how they are in the resources in lovelace…what I noticed tho is it is looking in /hacsfiles/ dir…i believe a few versions back HA moved those to /community.

I could just copy that dir and make /hacsfiles again and then go through and change the resources in lovelace, but was hoping to see if you know that would fix my issue before i go throug all that…(still gotta look to see if there is a file I can change instead of using the gui to change all those).

The button card seems to work fine on the front page. I do now get a little sensor in the corner of the climate and lighting buttons too…which is strange i see the sensor on the lighting button but the lighting page is blank.

Any guidance would be much appreciated…anything else I can suppy that would help please let me know. thank you sir.


[email protected]:/usr/share/hassio/homeassistant/www/community$ pwd
/usr/share/hassio/homeassistant/www/community
[email protected]:/usr/share/hassio/homeassistant/www/community$ 
[email protected]:/usr/share/hassio/homeassistant/www/community$ ls
Home-Assistant-Lovelace-HTML-Jinja2-Template-card  ha-card-weather-conditions	 lovelace-text-input-row
Home-Assistant-Lovelace-Local-Conditional-card	   light-entity-card		 lovelace-thermostat-card
Homekit-panel-card				   light-entity-row		 lovelace-time-picker-card
air-visual-card					   light-popup-card		 lovelace-xiaomi-vacuum-card
atomic_calendar					   lovelace-auto-entities	 lovelace-xiaomi-vacuum-map-card
banner-card					   lovelace-card-mod		 media_player-popup-card
bar-card					   lovelace-card-preloader	 mini-graph-card
button-card					   lovelace-card-templater	 mini-media-player
button-entity-row				   lovelace-card-tools		 nest-layout-card.js
button-text-card				   lovelace-darksky-card	 search-card
button-toolbar					   lovelace-fold-entity-row	 secondaryinfo-entity-row
calendar-card					   lovelace-gap-card		 sidebar-card
check-button-card				   lovelace-gui-sandbox		 simple-thermostat
clock-card					   lovelace-hui-element		 simple-weather-card
config-template-card				   lovelace-layout-card		 stack-in-card
cover-popup-card				   lovelace-light-with-profiles  swipe-card
custom-header					   lovelace-mini-thermostat	 switch-popup-card
custom-sidebar					   lovelace-more-info-card	 text-divider-row
custom-sonos-card				   lovelace-multiple-entity-row  text-element
decluttering-card				   lovelace-paper-buttons-row	 thermostat-popup-card
deep-press					   lovelace-roomba-vacuum-card	 upcoming-media-card
entity-attributes-card				   lovelace-slider-entity-row	 vacuum-card
garbage-collection-card				   lovelace-state-switch	 vertical-stack-in-card
ha-card-waze-travel-time			   lovelace-template-entity-row  weather-card
[email protected]:/usr/share/hassio/homeassistant/www/community$

Ok first, light can only be shown on the lights view. Your config seems right. Though you might need to play around with the floor selector on those views (invoke edit mode and then play around with the floor selector). You can enable edit mode by press and holding one of the three icons at the top right corner of the screen. Note that edit mode is on a per view basis and you will need to go to the specific view before/after invoking the edit mode. Alternatively you can enable edit mode through HKI Settings > Global Config.

As for the resources, community was the folder before HACS 0.9 or something and is now deprecated. Resources are found in the hacsfiles folder and you shouldn’t need to change that. If you have installed HACS and install the addons it will automatically place them there. As for the resources to add you will need to add them in the UI.

So now lets go on to the errors. The errors are shown because there are a lot of hidden cards (conditional) which might have no config setup at all. If you don’t use those cards it won’t be a problem and you can safely ignore those errors. If you really don’t like those errors you could fill in some dummy config in the settings for each and every setting (e.g. switch.nothing). But honestly I wouldn’t waste my time on that. Some errors are caused by addons that haven’t been correctly updated for newer HA versions and there is nothing I can do about those.
The errors are shown because it tries to do something that either doesn’t exist yet or is misconfigured. But again, for example on the frontpage, if you don’t use the garbage collector widget it won’t show on the frontpage, though the code is still there and thus will throw an error in your browser. (it doesn’t change the functionality though so no worries there)

Also I’d like to remind you that joining our discord server (find the link in the first post of this thread or on my repo) will get you answers faster :smiley: