HomeKit ZigBee Issue

Tags: #<Tag:0x00007fc4052f41a0> #<Tag:0x00007fc4052f40d8> #<Tag:0x00007fc4052f4010>

Hello,

i have an Issue with Home Assisant + HomeKit + ZigBee.
I have several Zigbee Plugs and Lights and when i turn them on/off in HomeKit, they turn on/off as they should, but after a second they turn on/off again but only in HomeKit and the Plug/Light itself will not turn on/off again, it just shows it as on/off in HomeKit…
When i turn them on/off in HomeAssistant the problem will not appear, Home Assistant shows them as on/off instantly.

I’m using ZigBee2mqtt.

Did anyone have the same issue and is there a solution?

Video

I am also having exactly the same issue and would be interested in a fix. My observations are:

  • It seemed to start after I have upgraded to iOS 15, or possibly after upgrading my ATV to the latest TVOS, however I have tried disabling the ATV and the problem remains.
  • My iPhone and AW are affected, my Macbook appears unaffected
  • HomeAssistant can control devices fine
  • I tried creating a new Bridge in the HK integration, this was also affected

Any help gratefully received.

Hi,

I am facing the exact same issue since I upgraded my devices to iOS 15. I am pretty sure that the iOS update is the reason for this since all devices which are still on iOS 14 don‘t have that issue. Also the Macbook acts normal.

Also a clean install of my iOS devices didn‘t help.

Would be great if someone could help to fix this very annoying problem.

Hey together,

seems fixed for me with the latest HA update core-2021.10.2.

1 Like