Homematic - set device parameters HM-CC-RT-DN for operation auto

Tags: #<Tag:0x00007f7398b8eeb8>

The goal was to set the operation auto parameter of my HM-CC-RT-DN in homeassistant with automations/scripts.

It took me some time to find the necessary info - so i decided to write this - maybe it save some time for others
This should work for all other homematic devices/params, too.

Home Assistant Version:
0.116.2
You are running an unsupported installation. Learn

My homematic devices are connected to a docker homegear container

configuration.yaml:

homematic:
  interfaces:
    rf:
      host: 192.168.0.2
      resolvenames: json
      username: Admin
      password: secret

To get the paramset for my devices i took homegear-manager - it has a good ui for copy&paste
No idea why it does not work on my W10 - on my Ubuntu VM the extracted tar.gz worked out of the box:
https://github.com/hobbyquaker/homematic-manager/releases/download/2.7.0/homematic-manager-2.7.0.tar.gz

found this but not tested:
datapoints.py

After succesful connection select the tab ‘RPC Konsole’ in homatic-manager

  • Select the command: getParamset
  • In Parameter: select your device (select the correct deviceID:channel e.g. OEQ0606969:0)
  • set paramset_key to MASTER

execute the command
The result for my HM-CC-RT-DN (OEQ0606969:0) :

{
  "ADAPTIVE_REGULATION": 2,
  "BACKLIGHT_ON_TIME": 10,
  "BOOST_AFTER_WINDOW_OPEN": false,
  "BOOST_POSITION": 80,
  "BOOST_TIME_PERIOD": 1,
  "BURST_RX": true,
  "BUTTON_LOCK": false,
  "BUTTON_RESPONSE_WITHOUT_BACKLIGHT": false,
  "CYCLIC_INFO_MSG": true,
  "CYCLIC_INFO_MSG_DIS": 0,
  ...
  "TEMPERATURE_WEDNESDAY_8": 17,
  "TEMPERATURE_WEDNESDAY_9": 17,
  "VALVE_ERROR_RUN_POSITION": 15,
  "VALVE_MAXIMUM_POSITION": 100,
  "VALVE_OFFSET": 0
}

Now i got a complete set of params to use for automation in home assistant.

Here an example for my HM-CC-RT-DN - before i called the service in homeassistant i set all TEMPERATURE_SUNDAY_ to 15 and all ENDTIME_SUNDAY_ to 1440 in homatic-manager.

To set the temperature on sunday: from 00:00 to 17:00 to 15 °C - from 17:00 to 17:30 to 20 °C - from 17:30 to 00:00 to 15 °C :

In home assistant developer tools services:

homematic.put_paramset

interface: rf
address: 'OEQ0606969:0'
#rx_mode: WAKEUP <- I think this will be implemented in next release ? - dont use it now 
paramset_key: MASTER
paramset: {"TEMPERATURE_SUNDAY_1": 15, "TEMPERATURE_SUNDAY_2": 20, "TEMPERATURE_SUNDAY_3": 15, "ENDTIME_SUNDAY_1": 1020, "ENDTIME_SUNDAY_2": 1050 }

Hit call service

In homatic-manager device tab -> select your device -> right click -> MASTER Paramset -if all went ok you will see your just changed params