HomematicIP generate the authentication token?

Please help fool :blush:
finally the new release of HA came with HmoeMaticIP support, and first where I stack is:
“generate the authentication token:”
how ? where ?

when use find -name “generate_auth_token.py” in terminal - with this name I don’t have any fail with this name

Ok I found information

Installation
Just run pip3 install homematicip to get the package

Usage
first run hmip_generate_auth_token.py (from the command line) to get an auth token for your access point. it will generate a “config.ini” in your current directory. The scripts will look for a config.ini in 3 different locations depending on your OS. Copy the file to one of these locations so that it will be accessable for the scripts.

BUT
what I got

(homeassistant) homeassistant@raspberrypi:/home/pi $ hmip_generate_auth_token.py 
/srv/homeassistant/bin/hmip_generate_auth_token.py: line 1: import: command not found
/srv/homeassistant/bin/hmip_generate_auth_token.py: line 2: import: command not found
/srv/homeassistant/bin/hmip_generate_auth_token.py: line 3: import: command not found
from: can't read /var/mail/builtins
/srv/homeassistant/bin/hmip_generate_auth_token.py: line 5: import: command not found
from: can't read /var/mail/homematicip.home
/srv/homeassistant/bin/hmip_generate_auth_token.py: line 8: import: command not found
/srv/homeassistant/bin/hmip_generate_auth_token.py: line 12: syntax error near unexpected token `('
/srv/homeassistant/bin/hmip_generate_auth_token.py: line 12: `def main():'

Instead of

try
python3 hmip_generate_auth_token.py

The way you have executed it doesn’t use Python as the interpreter.

I made clear install Hassbian Home Assistant version 0.67.1 -and first and only one thing I try to install on clean system - I got this error

pi@hassbian:~/.local/bin $ python3 hmip_generate_auth_token.py
Please enter the accesspoint id (SGTIN): 3014-F711-A000-03D5-699F-XXXX

Traceback (most recent call last):
File “hmip_generate_auth_token.py”, line 70, in
main()
File “hmip_generate_auth_token.py”, line 20, in main
home=Home()
File “/home/pi/.local/lib/python3.5/site-packages/homematicip/home.py”, line 112, in init
connection = Connection()
File “/home/pi/.local/lib/python3.5/site-packages/homematicip/base/base_connection.py”, line 44, in init
“language”: locale.getdefaultlocale()[0],
File “/usr/lib/python3.5/locale.py”, line 558, in getdefaultlocale
return _parse_localename(localename)
File “/usr/lib/python3.5/locale.py”, line 486, in _parse_localename
raise ValueError(‘unknown locale: %s’ % localename)
ValueError: unknown locale: UTF-8

same error coming whatever I put the SGTIN row

Hei! any advice ?!

Hey,
now HA version 0.69.1 is released and some witch had some updates for homematiicip as well, but I’m still stuck and can’t get the stuff to work - actually can’t generate token ;( upgraded hassbian and home assistant but error is still the same.