How do I add my Orvibo S20 switch to HA please?

So with lots of googling and reading through the forum, and watching some youtubes, I figured out how to actually add the yaml config to configureation.yaml (you guys don’t make it easy to find how!).

This is what I now have in configuration.yaml:

switch:
  - platform: orvibo
    discovery: false
    switches:
    - host: 192.168.20.58
      mac: AC:CF:23:4F:63:6C
      name: "Air Purifier Smart Plug"

But now what? I don’t understand what I need to do next to make it appear anywhere as a device.

When I go to Settings | Devices, it doesn’t show there, or under Devices or Entities.

I seem to be missing something, but don’t know what.
Some help please - 100% newbie here.

Thanks in advance
Paul

Did you restart Home Assistant? Restarting forces it to read the contents of configuration.yaml.

I’ll give that a crack now, thanks.

I also saw mention of a switches.yaml, so created that and added the same config there, just in case. But can’t see where that is referenced. Any ideas on that?

Restarting did the trick, thanks so much!.

Funny, I don’t remember reading that anywhere as part of the process. Never mind.

1 Like