How do I delete a Lovelace UI Card

Properly a silly question - but how do I delete a Lovelace card from the UI?
When I’m in the Overview section and select Configure UI I do get into the “Editor mode” where I can add or change cards. When I press the 3 vertical dots in the lower right corner of the card I do get 2 options - Move and Delete and while Move appears to work fine - Delete doesn’t do anything.
I’ve tried to restart HA but it doesn’t change the result.
I’m running the latest 0.89.2 on a Raspberry Pi 3B+

In editor mode, if you select the upper right menu again, you get to the raw mode editor.

So I did try that and deleted the lines which I believe belonged to the entities I couldn’t delete. The problem then was that I couldn’t save and exit the Raw Editor!
I even tried to reboot HA but when it was back up it was still in the Raw Editor mode!
Any suggestions ? Also - shouldn’t Delete work for the UI Cards?


hello, make sure you have only one web page Home assistant open, I had the same problem tonight

It also may be a popup or ad-blocker issue. It pops up a confirmation dialog when you hit “delete”. I had to disable all of my web blocking extensions to get the various pieces of Hass to work.

I have a similar issue attempting to delete a card (in this case it has multiply history graphs). I am in “Configure UI” and I select from the three dots the “delete card”. However the “cancel” and “delete” fields are below the web screen (unless I ‘maximize’ the windows … using firefox browser)…

The scroll bar does not move the delete popup box… thus I can’t see the bottom portion of the popup box that has the ‘cancel and delete’ active text buttons

I am having a similar issue- deleted card on main overview reappears after a restart,Have checked the lovelace file in .storage and it isnt there.

Any ideas folks?