How do you disable the onboard Bluetooth - on Pi4?

Hi
The onboard BT on my Pi4 only has a range of about 6-9ft, so instead I use a BT dongle on an extension lead which subsequently gave me excellent range in my home.

Before I installed the dongle the BT available was:

HCI0

After installation, the following were available:

HCI0
HCI1

For some reason the dongle BT was automatically defined as the (default) HCI0 rather than 1, but I set it up with the Bluetooth Integration (2022.8) and it worked fine until today.
Today my BT device(s) were unresponsive and in the end it was resolved with a simple reboot.

My concern is that HASSIO might be randomising the BT default assignment on start-up and maybe I’ve just lucky so far that the default HCI0 has stayed as the dongle.

It shouldn’t be, but in case it is I’m looking or a way to disable the on-board BT so that this is guaranteed not to happen.

What I tries so far:
hclitool and hcliconfig don’t work within HASSIO OS

rfkill help does work, but rfkill list isn’t allowed, even with SSH protection disabled

bluetoothcli does work so I selected the onboard bluetooth and tried bluetoothcli agent off
and bluetoothcli power off on the onboard controller, but it didn’t seem to do much of anything.

I did find some useful information on this page, but udevadm and the “/etc/udev/rules” path don’t exist in HAOS

Any help would be appreciated.

2022.9 will track the adapter by mac address so you won’t have to worry about it picking the wrong one if they move around

1 Like

I’ve added a ASUS controller, but it is not used. How can I force disabling the onboard controller on a mini PC ?