How does one remove wink integration?

Setup: Unraid with Home Assistant in official docker.

Right now wink is borked and I’m done playing with it for now. I don’t see how to remove the wink intigration. I remove the .wink.conf file, but upon restart, HA re-creates it. It’s like there’s some underlying database it’s pulling the info from.

I don’t see a Wink Integration in my web ui (never have after the integration wizard was finished.

Is there any suggestions or steps of what I need to do?

I think you need to go into configuration.YAML and remove the wink: entry.
Restart HA and it should disappear.

just tried this. No joy.

ssh as root into your system. Go to /config/.storage. Delete file core.entity_registry. Restart.

Did this… deleted the .wink.conf again as well… restarted… Wink devices still being pulled in and wink conf file auto created.

Okay… try the above again but also delete core.restore_state

That worked! Thank you!

Some of my entity names changed (MyQ Garage door and a few switches) but it’s FINALLY removed. When the wink intigration gets fixed, I’ll re-set it up.

I don’t suppose you might know if HA has local access to Wink when I revisit this in the future.

Local control does seem to be an option but I’m not sure how well it is supported here. With the recent outages of Wink cloud (including the issue this week that was patched on the fly thanks to some fine folks here)… I’m considering migrating to a zwave+zigbee stick and am grateful that I was able to purchase my two wink hubs (one for local, one for remote) while they were on sale for $30/each.

I have old device trackers in known devices of an integration from tomatousb as well as some duplicate z wave thermostat that is present (not sure why) is this method you speak still the preferred method to delete stubborn entities?

I’m not sure if it is the preferred method… probably not, but it worked for me.

I have a stubborn entity for a samsung tv that I can’t delete, i have it commented out in my yaml, and I have deleted the db, entity registry file, AND the restore state file. Any other ideas?

Try putting this in your configuration:


discovery:
  ignore:
    - samsung_tv

That was going to be my guess that is coming in from a discovery. I have left it there for now, as I plan to integrate it later

Thanks again, now i know!