How to change from wifi connection to LAN?

Hi, my HA recently having a weird issue in which it is dropping from the network as I can’t access the Lovelace UI neither through DuckDNS or local IP. When I check my router, I’m seeing it actually is still connected to my router, but I wasn’t able to ping it with my Windows desktop.

The only to recover it is by rebooting the router and I wasn’t sure what is root cause of this as I didn’t did any changes recently. My RPi4 is currently connects through wifi and I’m thinking to switch to ethernet and see if it solves the problem but I wasn’t sure how can I do it.

Please advise.

Plug in a cable?

1 Like

Yes, go for LAN cable, but keep in ind that this will change the ip of you HA instance. You obviously have to account for that.

Can’t we use the same IP address for the LAN? I see there is an option to disable the ipv4 under with Wlan section in the UI. Can I disable the ipv4 in the wlan section then use the same ip address in eth section?

you could, but by default your router will give a new ip to the raspberry when you connect it to the lan instead of the wifi. That is because, from the routers point of view, these are two different devices. However If you don’t know how these kind of network things work, I guess you have to spent a lot of time understanding this and then configure it to your liking. Its not hard or difficult. Just from your question I judge, you have little to no experience with this and I think then it is easier, to update your clients and what not to take the new ip address into account, as this is a configuration you have already done once before.

Oh i see. I got what you mean. I can reserve the same ip address for the ethernet in the router as long as i know the mac address of the ethernet. And of course I need to remove the reserved ip that is created for the wlan connection.

year exactly, and you have to tell the router to give the old IP address to the new Ethernet device.

1 Like